Opened 9 years ago

Closed 9 years ago

#8944 closed defect (Duplicate)

MBE responsiveness slows until dead after adding SBE

Reported by: James Crow <crow.jamesm@…> Owned by:
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.23.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am running Mythbuntu amd64 9.10 on my MBE. Myth version is 0.23.1-26231. I recently added a SBE running Mythbuntu 10.04 amd64. The same exact version of Myth is running on both. With the SBE running the MBE slows its responsiveness down over time. Yesterday I restarted both the MBE and SBE at 5PM. By 11PM I was no longer able to view any recordings. Additionally it takes longer and longer to navigate the View Recordings screen and to get the status page in Mythweb. Recordings appeared to continue normally during this time. At 11PM I restarted both the MBE and SBE. I was immediately able to view the recording that failed a few minutes earlier. Both BE machines were running with -v network,extra,socket. This might be related to ticket 7608, but this is version 0.23.1 not 0.22. The uncompressed log files are between 60 and 70 MB per BE (5MB to 7MB compressed).

For search aiding I see these types of errors in my log: 2010-09-15 20:00:04.059 MythSocket?(1d574e0:-1): writeStringList: Error, socket went unconnected. 2010-09-15 20:00:06.805 MythSocket?(1f91090:-1): writeStringList: Error, No data written on writeBlock (1 errors) 2010-09-15 20:00:06.888 MythSocket?(1fe0b20:-1): writeStringList: Error, No data written on writeBlock (1 errors) 2010-09-15 20:00:18.784 MythSocket?(1234010:-1): writeStringList: Error, No data written on writeBlock (1 errors) 2010-09-15 20:00:23.501 MythSocket?(16b6720:-1): writeStringList: Error, socket went unconnected. 2010-09-15 20:00:38.349 MythSocket?(7f1a486dc540:-1): writeStringList: Error, No data written on writeBlock (1 errors) 2010-09-15 20:30:44.349 MythSocket?(7f1a48455050:-1): writeStringList: Error, socket went unconnected. 2010-09-15 20:30:44.982 MythSocket?(7f1a48449300:-1): writeStringList: Error, socket went unconnected.

I don't know if it is related or important, but I am also seeing some many mythcommflag segfaults in the system log. The message lists either libmythdb or some qt library.

Attachments (4)

mbe_first_minutes.log.gz (213.1 KB) - added by James Crow <crow.jamesm@…> 9 years ago.
First 10 minutes of MBE writeStringList Error at 16:57
sbe_first_minutes.log.gz (123.7 KB) - added by James Crow <crow.jamesm@…> 9 years ago.
SBE log of same time. MBE shows error at 16:57 none show in SBE log
mbe_2100.log.gz (165.2 KB) - added by James Crow <crow.jamesm@…> 9 years ago.
MBE log from 21:00 (+/- 5 mins) There are lots of writeStringList Error entries
sbe_2100.log.gz (155.2 KB) - added by James Crow <crow.jamesm@…> 9 years ago.
SBE log from 21:00 (+/- 5 mins) There are lots of writeStringList Error entries

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by James Crow <crow.jamesm@…>

Attachment: mbe_first_minutes.log.gz added

First 10 minutes of MBE writeStringList Error at 16:57

Changed 9 years ago by James Crow <crow.jamesm@…>

Attachment: sbe_first_minutes.log.gz added

SBE log of same time. MBE shows error at 16:57 none show in SBE log

Changed 9 years ago by James Crow <crow.jamesm@…>

Attachment: mbe_2100.log.gz added

MBE log from 21:00 (+/- 5 mins) There are lots of writeStringList Error entries

Changed 9 years ago by James Crow <crow.jamesm@…>

Attachment: sbe_2100.log.gz added

SBE log from 21:00 (+/- 5 mins) There are lots of writeStringList Error entries

comment:1 Changed 9 years ago by robertm

Resolution: Duplicate
Status: newclosed

Dupe of #7608 and/or #8526.

Note: See TracTickets for help on using tickets.