Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 21 months ago

#8983 closed Bug Report - General (fixed)

Channel scanner always deletes existing channels

Reported by: Richard <mythtv@…> Owned by: danielk
Priority: minor Milestone: 0.26
Component: MythTV - Channel Scanner Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Every time I run a channel scan, it always seems to decide that my existing (working) channels are off-air and wants to delete them. It then re-adds them all wiping out all my xmltv mappings.

Version details:

Please attach all output as a file in bug reports.
MythTV Version   : 26319M
MythTV Branch    : trunk
Network Protocol : 62
Library API      : 0.23.20100913-1
QT Version       : 4.5.3
Options compiled in:
 linux profile using_alsa using_oss using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

mythtv-setup -v channelscan,database log attached.

Attachments (3)

chanscan.log (257.1 KB) - added by Richard <mythtv@…> 4 years ago.
pre-scan.sql (11.3 KB) - added by Richard <mythtv@…> 4 years ago.
channel and dtv_multiplex tables before the scan
post-scan.sql (40.6 KB) - added by Richard <mythtv@…> 4 years ago.
channelscan, channelscan_channel and channelscan_dtv_multiplex tables after the scan

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by Richard <mythtv@…>

comment:1 Changed 4 years ago by danielk

  • Status changed from new to infoneeded_new

Please provide the contents of the channel and dtv_multiplex tables before the scan, the channelscan, channelscan_channel and channelscan_dtv_multiplex tables after the scan, and two examples of channels that MythTV erroneously wanted to delete.

Changed 4 years ago by Richard <mythtv@…>

channel and dtv_multiplex tables before the scan

Changed 4 years ago by Richard <mythtv@…>

channelscan, channelscan_channel and channelscan_dtv_multiplex tables after the scan

comment:2 Changed 4 years ago by Richard <mythtv@…>

Pre and post-scan tables attached.
As for example channels - it's pretty-much all of them. Try channels 1 (ONE HD) and 2 (ABC1).

My original thought was that there was something amiss with the existing channel data - but the problem occurs on each channel scan even if I clear all channels beforehand.

comment:3 Changed 4 years ago by danielk

  • Status changed from infoneeded_new to new

comment:4 Changed 4 years ago by kenni

  • Status changed from new to assigned

comment:5 Changed 2 years ago by stuartm

  • Severity changed from medium to high
  • Type changed from defect to Bug Report - General

comment:6 Changed 21 months ago by danielk

  • Milestone changed from unknown to 0.26
  • Status changed from assigned to accepted

It appears the problem is that the dtv_multiplex rows in the DB do not have a networkid set and
because of this the IsSameChannel?() check in ChannelImporter::CleanupDuplicates?() fails.

comment:7 Changed 21 months ago by Daniel Kristjansson <danielk@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In 9b8a005c0b5df7378d6db4c54a8cfdd3277fe0c1/mythtv:

Fixes #8983. Allow relaxed matching of channels in DB.

If the user has incomplete channel info in their DB still try
to match them as best as we can to channels found in the scan.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.