Opened 9 years ago

Closed 9 years ago

#9026 closed defect (Duplicate)

Backend lockup

Reported by: Richard <mythtv@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Whilst trying to watch a video while the backend was recording, the frontend reported socket timeouts.

The backend process appeared to be consuming excessive CPU, so I attached the debugger and obtained the following backtrace:

#0  0x00007f825ab38049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f825b691cd3 in QMutexPrivate::wait (this=0x827480, timeout=-1) at thread/qmutex_unix.cpp:80
#2  0x00007f825b68d895 in QMutex::lock (this=0x820840) at thread/qmutex.cpp:169
#3  0x00000000004b0dbd in relock (this=<value optimized out>) at /usr/include/QtCore/qmutex.h:120
#4  QMutexLocker (this=<value optimized out>) at /usr/include/QtCore/qmutex.h:102
#5  Scheduler::GetRecStatus (this=<value optimized out>) at scheduler.cpp:1490
#6  0x000000000049df7b in MainServer::customEvent (this=<value optimized out>, e=<value optimized out>) at mainserver.cpp:1019
#7  0x00007f825b787335 in QObject::event (this=0x82dea0, e=0x7f82400ea0f0) at kernel/qobject.cpp:1142
#8  0x00007f825b777ddc in QCoreApplication::notifyInternal (this=0x7ffff61c0930, receiver=0x82dea0, event=0x7f82400ea0f0) at kernel/qcoreapplication.cpp:610
#9  0x00007f825b7789ea in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#10 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#11 0x00007f825b7a0803 in sendPostedEvents () at kernel/qcoreapplication.h:218
#12 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#13 0x00007f825ad84dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#14 0x00007f825ad887b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#15 0x00007f825ad888e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#16 0x00007f825b7a03a3 in QEventDispatcherGlib::processEvents (this=0x7b1250, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#17 0x00007f825b776712 in QEventLoop::processEvents (this=<value optimized out>, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:149
#18 0x00007f825b776ae4 in QEventLoop::exec (this=0x7ffff61c0490, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:201
#19 0x00007f825b778c99 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#20 0x00000000005445da in run_backend (cmdline=<value optimized out>) at main_helpers.cpp:791
#21 0x000000000044b3f4 in main (argc=4, argv=<value optimized out>) at main.cpp:184

Version details:

MythTV Version   : 26319M
MythTV Branch    : trunk
Network Protocol : 62
Library API      : 0.23.20100913-1
QT Version       : 4.5.3
Options compiled in:
 linux profile using_alsa using_oss using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

This problem looks very similar to that mentioned by Tomi Orava in http://svn.mythtv.org/trac/ticket/8952. Not sure if it is really related or not.

Relevent bit of the backend log attached. Note: It appears to have had some sort of device contention around the same time.

For what it's worth - I dumped a core file at the time of the issue. Let me know if there is more data required.

Attachments (1)

mythbackend.log (14.1 KB) - added by Richard <mythtv@…> 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Richard <mythtv@…>

Attachment: mythbackend.log added

comment:1 Changed 9 years ago by robertm

Resolution: Duplicate
Status: newclosed

Dupe of #9016/#8952.

Note: See TracTickets for help on using tickets.