Opened 9 years ago

Closed 8 years ago

#9034 closed Bug Report - General (Duplicate)

Error Opening jump program file buffer in Live TV

Reported by: ligverd@… Owned by:
Priority: trivial Milestone: unknown
Component: MythTV - Recording Version: Master Head
Severity: low Keywords: Live TV igmp
Cc: Ticket locked: yes

Description (last modified by beirdo)

System: Qt-4.6.3 NVidia 195.36.24 mythtv svn from r262?? to r26592

Live TV UDP Multicast have almost always error: "Error Opening jump program file buffer"

tcpdump -n -i eth1 igmp

First run Live TV

06:08:11.539080 IP 10.242.44.105 > 224.0.0.2: igmp leave 230.0.1.20
06:08:11.544583 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20
06:08:12.438036 IP 10.248.18.161 > 230.0.1.20: igmp query v2 [max resp time 10] [gaddr 230.0.1.20]
06:08:12.784576 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20
06:08:13.440329 IP 10.248.18.161 > 230.0.1.20: igmp query v2 [max resp time 10] [gaddr 230.0.1.20]
06:08:14.257909 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20

All right, look ... Switch the channel

06:08:20.981990 IP 10.242.44.105 > 224.0.0.2: igmp leave 230.0.1.20
06:08:21.077927 IP 10.242.44.105 > 230.0.1.54: igmp v2 report 230.0.1.54
06:08:21.440232 IP 10.248.18.161 > 230.0.1.20: igmp query v2 [max resp time 10] [gaddr 230.0.1.20]
06:08:22.291240 IP 10.242.44.105 > 230.0.1.54: igmp v2 report 230.0.1.54
06:08:22.440099 IP 10.248.18.161 > 230.0.1.20: igmp query v2 [max resp time 10] [gaddr 230.0.1.20]
06:08:23.298522 IP 10.242.44.105 > 224.0.0.2: igmp leave 230.0.1.54
06:08:23.442619 IP 10.248.18.161 > 230.0.1.54: igmp query v2 [max resp time 10] [gaddr 230.0.1.54]
06:08:23.451667 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20
06:08:24.440503 IP 10.248.18.161 > 230.0.1.54: igmp query v2 [max resp time 10] [gaddr 230.0.1.54]
06:08:28.318322 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20
06:08:33.454237 IP 10.242.44.1 > 224.0.0.1: igmp query v2
06:08:33.455514 IP 10.250.44.1 > 224.0.0.1: igmp query v2
06:08:33.457003 IP 10.248.18.161 > 224.0.0.1: igmp query v2
06:08:34.344571 IP 10.242.44.105 > 230.0.1.20: igmp v2 report 230.0.1.20
06:08:39.514587 IP 10.242.44.105 > 239.255.255.250: igmp v2 report 239.255.255.250

Crashes with error: "Error Opening jump program file buffer"

after which the multicast stream 230.0.1.20 continues to run

moment of switching are two threads together. :(

Attachments (9)

mythbackend.log (207.0 KB) - added by ligverd@… 9 years ago.
mythbackend -v file,network
mythfrontend.log (160.1 KB) - added by ligverd@… 9 years ago.
mythfrontend -v playback,file
mythbackend-r26977.log (3.5 KB) - added by ligverd@… 9 years ago.
mythfrontend-r26977.log (4.7 KB) - added by ligverd@… 9 years ago.
tcpdump-r26977.log (2.7 KB) - added by ligverd@… 9 years ago.
Mythbackend-v0.25pre-1623-ge682122.txt (9.3 KB) - added by raymondboettcher@… 9 years ago.
Mythbackend GE682122
Mythfrontend-v0.25pre-1623-ge682122.txt (4.5 KB) - added by raymondboettcher@… 9 years ago.
Mythfrontend GE682122
Mythbackend-v0.25pre-1524-gc611adb.txt (97.8 KB) - added by raymondboettcher@… 9 years ago.
Mythfrontend-v0.25pre-1524-gc611adb.txt (12.1 KB) - added by raymondboettcher@… 9 years ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

Can you please attach backend and frontend logs with the following options?

mythbackend -v file,network

mythfrontend -v playback,file

comment:2 Changed 9 years ago by robertm

Milestone: 0.24unknown
Priority: criticaltrivial
Severity: highlow

Oh, and please read the ticket howto, do not set milestones, priority, or severity on tickets!

Changed 9 years ago by ligverd@…

Attachment: mythbackend.log added

mythbackend -v file,network

Changed 9 years ago by ligverd@…

Attachment: mythfrontend.log added

mythfrontend -v playback,file

comment:3 Changed 9 years ago by anonymous

in mythtv-r25899 this is not observed, multicast captures well

comment:4 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Status: newassigned

comment:6 Changed 9 years ago by ligverd@…

mythtv-0.24rc1 + mythtv-r26977

I probably repeat myself, but the error is and is not possible to use IPTV

Logs attached:

Changed 9 years ago by ligverd@…

Attachment: mythbackend-r26977.log added

Changed 9 years ago by ligverd@…

Attachment: mythfrontend-r26977.log added

Changed 9 years ago by ligverd@…

Attachment: tcpdump-r26977.log added

comment:7 Changed 9 years ago by bwobbones

I had this error, it was because mythbackend was running as a user that was different to the owner of the video files recorded by live tv and the disk space ran out. mythbackend reported no space left on device.

comment:8 Changed 9 years ago by tralph

Status: assignedinfoneeded

Is this still a problem with the latest code?

comment:9 Changed 9 years ago by ligverd@…

The situation is as follows. Somewhere in version 0.24svn on the same computer everything is normal, the other is almost always (in time) throws out the mistake. : ( If other users have complained about this bug in IPTV, close this ticket. We assume that the problem in my software (even though all variables set). : ( Thank you that do not forgotten. :)

comment:10 Changed 9 years ago by tralph

Please update to the *very* latest build based on the newer git repo. The default LiveTV ring buffer open file timeout has been increased from 2 to 10 seconds. The frontend may have just not waited long enough. Your logs indicate that the frontend received no data within the first 2 seconds of opening the ring buffer. Maybe with the increased timeout data will arrive.

comment:11 Changed 9 years ago by beirdo

Owner: changed from Janne Grunau to tralph

comment:12 Changed 9 years ago by anonymous@…

FYI: openSUSE 11.4 x64 KDE4.6. WinTV-HVR-950Q. Both the binaries from Packman repo and manual compilation from latest svn 0.24 have same problem. All works fine until some error happens (like selecting an encrypted channel). After the 1st crash, it keeps getting Error Opening jump program file buffer in Live TV. Seems to have something to do with the channels Right now, it starts OK with the last channel that worked but has the error when trying to switch channels. When changing the default start channel to other (that used to work) it directly comes up with the error (or simply crashes). On this PC, mythtv worked just fine with openSUSE 11.1 x64 KDE3.5. But as soon as I installed fresh openSUSE 11.3 x64 KDE4.4 the errors started. IMHO this is not "trivial" priority.

comment:13 Changed 9 years ago by raymondboettcher@…

I know no bump.. However, this is the exact failure code using MythTV 0.24+fixes (mythtv-80192ec). The tuner works the first time but if you leave Live TV and return later this error occurs every time. To clear it, you must restart mythbackend! I know a stream is being delivered because I'm delivering it. The Tuner seems to open then close and then open a second time before it starts the feed. Maybe Mythfrontend is still attached to the first instance which never gets data because it closed and reopened it?? I will GLADLY test this with latest master and rec2 branchs, stand by... (Reference: One of the issues I spoke of in Ticket #9670).

comment:14 Changed 9 years ago by raymondboettcher@…

Status: infoneededassigned

This is not testable in the Master Branch (mythtv-v0.25pre-1623-ge682122), there is definitely a mutex lock scenario going on causing a hang in mythbackend... The problem is causing mythbackend to become unresponsive to the frontend. It ends poorly with the frontend dropping out (after a minute or so) of Live TV saying that there is "no tuners free for live tv".

Changed 9 years ago by raymondboettcher@…

Mythbackend GE682122

Changed 9 years ago by raymondboettcher@…

Mythfrontend GE682122

comment:15 Changed 9 years ago by raymondboettcher@…

This particular error doesn't turn up in rec2 branch (mythtv-v0.25pre-1524-gc611adb)... However, getting playback is still impossible but at least it doesn't deadlock. Instead it seems to refuse opening the ringbuffer file because its 0 bytes. I get a LAM Lock but no feed and an error about opening the RingBuffer? file. Network Tuner isn't directing the stream to the ringbuffer perhaps? It also complains "SendMythSystemPlayEvent?() called with empty ProgramInfo?" but technically there is no program info because I have the IPTV Tuner assigned to no grabber. I'm not sure why that would throw an error, perhaps pass it "Unknown" as the program name? MythTV 0.23.1 seems to do that.

Changed 9 years ago by raymondboettcher@…

Changed 9 years ago by raymondboettcher@…

comment:16 Changed 8 years ago by tralph

Owner: tralph deleted
Status: assignednew

comment:17 Changed 8 years ago by beirdo

Description: modified (diff)
Type: defectBug Report - General

comment:18 Changed 8 years ago by robertm

Ticket locked: set

comment:19 Changed 8 years ago by Raymond Wagner

Component: MythTV - Video PlaybackMythTV - Recording
Resolution: Duplicate
Status: newclosed

New ticket started at #10178. Closing this one.

Note: See TracTickets for help on using tickets.