Opened 9 years ago

Closed 8 years ago

#9167 closed defect (Duplicate)

Full channel scan writes wrong frequency for transport

Reported by: lyricnz@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.23-fixes
Severity: medium Keywords: australia, channel 9, tuning
Cc: Ticket locked: no

Description

Performing a full channel scan (empty channels+transports) successfully found 23 channels across 6 transports (including channel names etc). However, the frequency saved in the DB was incorrect, meaning that one transport could not be tuned. Here's the console output during channel scan:

2010-11-02 01:00:45.613 Loading menu theme from /usr/share/mythtv/setup.xml
2010-11-02 01:00:45.649 Using NV NPOT texture extension
2010-11-02 01:00:51.302 XMLParseBase: Loading window theme from /usr/share/mythtv/themes/Terra/config-ui.xml
2010-11-02 01:00:51.347 New DB connection, total: 2
2010-11-02 01:00:51.348 Connected to database 'mythconverg' at host: localhost
2010-11-02 01:00:51.349 New DB connection, total: 3
2010-11-02 01:00:51.351 Connected to database 'mythconverg' at host: localhost
auto:177500000:7 Digital:7:12830:4115:1328:1283=1283:dvb        0:cnt(pnum:1,channum:1)
auto:177500000:7 Digital 1:71:12830:4115:1329:1283=1283:dvb     0:cnt(pnum:1,channum:1)
auto:177500000:7TWO:72:12830:4115:1330:1283=1283:dvb    0:cnt(pnum:1,channum:1)
auto:177500000:7mate:73:12830:4115:1331:1283=1283:dvb   0:cnt(pnum:1,channum:1)
auto:177500000:7 Digital:70:12830:4115:1332:1283=1283:dvb       0:cnt(pnum:1,channum:1)
auto:191500000:Nine Digital:9:12829:4114:1072:1072=1072:dvb     0:cnt(pnum:1,channum:1)
auto:191500000:GEM:90:12829:4114:1073:1072=1072:dvb     0:cnt(pnum:1,channum:1)
auto:191500000:GO!:99:12829:4114:1074:1072=1072:dvb     0:cnt(pnum:1,channum:1)
auto:219500000:ONE HD:1:12831:4116:1585:1539=1539:dvb   0:cnt(pnum:1,channum:1)
auto:219500000:TEN Digital:10:12831:4116:1589:1539=1539:dvb     0:cnt(pnum:1,channum:1)
auto:219500000:ONE HD:11:12831:4116:1591:1539=1539:dvb  0:cnt(pnum:1,channum:1)
auto:219500000:ONE Digital:12:12831:4116:1592:1539=1539:dvb     0:cnt(pnum:1,channum:1)
auto:226500000:ABC News 24:24:12827:4112:560:561=561:dvb        0:cnt(pnum:1,channum:1)
auto:226500000:ABC1:2:12827:4112:561:561=561:dvb        0:cnt(pnum:1,channum:1)
auto:226500000:ABC2:22:12827:4112:562:561=561:dvb       0:cnt(pnum:1,channum:1)
auto:226500000:ABC1:21:12827:4112:563:561=561:dvb       0:cnt(pnum:1,channum:1)
auto:226500000:ABC3:23:12827:4112:564:561=561:dvb       0:cnt(pnum:1,channum:1)
auto:536500000:SBS ONE:3:12802:12802:785:784=784:dvb    0:cnt(pnum:1,channum:1)
auto:536500000:SBS TWO:32:12802:12802:786:784=784:dvb   0:cnt(pnum:1,channum:1)
auto:536500000:SBS 3:33:12802:12802:787:784=784:dvb     0:cnt(pnum:1,channum:1)
auto:536500000:SBS 4:34:12802:12802:788:784=784:dvb     0:cnt(pnum:1,channum:1)
auto:536500000:SBS HD:30:12802:12802:789:784=784:dvb    0:cnt(pnum:1,channum:1)
auto:557500000:C31:44:12832:12832:3585:3584=3584:dvb    0:cnt(pnum:1,channum:1)

Found 6 transport(s):
Channels: FTA Enc Dec
ATSC        0   0   0
DVB        23   0   0
SCTE        0   0   0
MPEG        0   0   0
NTSC        0
Unique: prog 23 atsc 0 atsc minor 0 channum 23
Max atsc major count: 0

2010-11-02 01:06:23.543 New DB DataDirect connection
2010-11-02 01:06:23.544 Connected to database 'mythconverg' at host: localhost
Insert(dvb): 7
Insert(dvb): 71
Insert(dvb): 72
Insert(dvb): 73
Insert(dvb): 70
Insert(dvb): 9
Insert(dvb): 90
Insert(dvb): 99
Insert(dvb): 1
Insert(dvb): 10
Insert(dvb): 11
Insert(dvb): 12
Insert(dvb): 24
Insert(dvb): 2
Insert(dvb): 22
Insert(dvb): 21
Insert(dvb): 23
Insert(dvb): 3
Insert(dvb): 32
Insert(dvb): 33
Insert(dvb): 34
Insert(dvb): 30
Insert(dvb): 44

The ones that are incorrect are:

auto:191500000:Nine Digital:9:12829:4114:1072:1072=1072:dvb     0:cnt(pnum:1,channum:1)
auto:191500000:GEM:90:12829:4114:1073:1072=1072:dvb     0:cnt(pnum:1,channum:1)
auto:191500000:GO!:99:12829:4114:1074:1072=1072:dvb     0:cnt(pnum:1,channum:1)

these are actually on 191625000 (as confirmed by Kaffeine). Updating the frequency in dtv_multiplex and restarting backend, and the channels work fine.

Some people in IRC suggest that there may be incorrect information being broadcast with these channels, and MythTV is using this when writing the frequencies. If it helps, I'm in Melbourne, Australia. Version is release-0-23-fixes branch, svn revision 25902

Attachments (1)

mythtv 9.png (500.9 KB) - added by anonymous 9 years ago.
Tuning information from Kaffeine

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by anonymous

Attachment: mythtv 9.png added

Tuning information from Kaffeine

comment:1 Changed 9 years ago by beirdo

Owner: set to Stuart Auchterlonie
Status: newassigned

comment:2 Changed 8 years ago by Stuart Auchterlonie

Can you attach logs from

mythtv-setup --verbose channelscan,channel,record,siparser

This will allow me to see what information is being signalled. Additionally the frequency listed in the output is different from the working frequency by the offset 12.5kHz, so it's possible it's using one of the offset frequencies in preference to the main (non offset) freq.

Stuart

comment:3 Changed 8 years ago by robertm

Resolution: Duplicate
Status: assignedclosed

Dupe of #9777 (and requested info no provided in 7 months anyway)

Note: See TracTickets for help on using tickets.