Opened 9 years ago

Closed 9 years ago

#9172 closed defect (Invalid)

Mythwelcome not launching mythfrontend

Reported by: anonymous Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - Mythwelcome & Mythshutdown Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi there,

Tonight I have upgraded (from rev 27009 to rev 27071) my mythtv 0.24 system (using mythbuntu 0.24 ppa). I have just found a bug in mythwelcome: pressing "enter" does not launch mythfrontend. If mythwelcome is launched from a terminal i get the following error log:

jose@amd64:~$ mythwelcome 2010-11-02 23:37:31.643 Using runtime prefix = /usr 2010-11-02 23:37:31.643 Using configuration directory = /home/jose/.mythtv 2010-11-02 23:37:31.644 Empty LocalHostName?. 2010-11-02 23:37:31.644 Using localhost value of amd64 2010-11-02 23:37:31.644 Testing network connectivity to '192.168.1.102' 2010-11-02 23:37:31.644 Launching: `ing -t 3 -c 1 2010-11-02 23:37:31.645 PID 3300: launched 2010-11-02 23:37:31.646 Starting reaper thread sh: i: not found 2010-11-02 23:37:31.746 PID 3300: exited: status=32512, result=127 2010-11-02 23:37:31.746 Launching: ping -c 1 192.168.1.102 >/dev/null 2>&1 2010-11-02 23:37:31.747 PID 3303: launched 2010-11-02 23:37:31.846 PID 3303: exited: status=0, result=0 2010-11-02 23:37:31.866 New DB connection, total: 1 2010-11-02 23:37:31.921 Connected to database 'mythconverg' at host: 192.168.1.102 2010-11-02 23:37:31.935 Closing DB connection named 'DBManager0' 2010-11-02 23:37:31.985 Connected to database 'mythconverg' at host: 192.168.1.102 2010-11-02 23:37:31.997 Current locale es_ES 2010-11-02 23:37:31.997 No locale defaults file for es_ES, skipping 2010-11-02 23:37:31.997 Launching: `sm 2010-11-02 23:37:32.000 PID 3306: launched sh: Syntax error: EOF in backquote substitution 2010-11-02 23:37:32.047 PID 3306: exited: status=512, result=2 2010-11-02 23:37:32.047 Launching: gnome-screensaver-command --help >&- 2>&- 2010-11-02 23:37:32.049 PID 3307: launched sh: Syntax error: EOF in backquote substitution 2010-11-02 23:37:32.147 PID 3307: exited: status=512, result=2 2010-11-02 23:37:32.149 DPMS is active. 2010-11-02 23:37:32.458 Desktop video mode: 1920x1080 60.000 Hz 2010-11-02 23:37:32.845 Loading es translation for module mythfrontend 2010-11-02 23:37:32.938 LIRC, Error: Failed to connect to Unix socket '/dev/lircd'

eno: No existe el archivo o directorio (2)

2010-11-02 23:37:32.938 JoystickMenuThread?: Joystick disabled - Failed to read /home/jose/.mythtv/joystickmenurc 2010-11-02 23:37:33.395 Using Frameless Window 2010-11-02 23:37:33.395 Using Full Screen Window 2010-11-02 23:37:33.587 Using the OpenGL painter 2010-11-02 23:37:33.635 OpenGL: OpenGL vendor : Advanced Micro Devices, Inc. 2010-11-02 23:37:33.635 OpenGL: OpenGL renderer: Mesa DRI R600 (RV770 9442) 20090101 TCL DRI2 2010-11-02 23:37:33.635 OpenGL: OpenGL version : 2.1 Mesa 7.10-devel 2010-11-02 23:37:33.635 OpenGL: Max texture size: 4096 x 4096 2010-11-02 23:37:33.635 OpenGL: Max texture units: 8 2010-11-02 23:37:33.636 OpenGL: Direct rendering: Yes 2010-11-02 23:37:33.636 OpenGL: Initialised MythRenderOpenGL 2010-11-02 23:37:34.106 MythCoreContext?: Connecting to backend server: 192.168.1.102:6543 (try 1 of 1) 2010-11-02 23:37:34.110 Using protocol version 63 2010-11-02 23:37:35.331 mythshutdown --startup returned: 1 2010-11-02 23:37:36.259 Locking input devices 2010-11-02 23:37:36.268 Launching: 2010-11-02 23:37:36.274 PID 3403: launched 2010-11-02 23:37:36.351 PID 3403: exited: status=0, result=0 2010-11-02 23:37:37.029 Unlocking input devices 2010-11-02 23:37:37.525 Locking input devices 2010-11-02 23:37:37.539 Launching: î2 2010-11-02 23:37:37.544 PID 3427: launched sh: 2010-11-02: not found 2010-11-02 23:37:37.552 PID 3427: exited: status=32512, result=127 2010-11-02 23:37:38.439 Unlocking input devices 2010-11-02 23:37:40.598 OpenGL: Deleting OpenGL Resources jose@amd64:~$

This log comes from a remote client. The error is also present at the server+client system.

I must add that the "enter" button does work when in mythwelcome menus (for example, if you press "m" you can select an item by pressing "enter"), so it looks like mythwelcome is not passing the appropriate mythfrontend command.

Should you need any further piece of information, please let me know.

Kind regards,

José

Change History (4)

comment:1 Changed 9 years ago by beirdo

Milestone: 0.24unknown
Owner: changed from Anduin Withers to beirdo
Status: newassigned

Please try [27084] or later. This should be fixed.

comment:2 Changed 9 years ago by beirdo

Status: assignedinfoneeded

comment:3 Changed 9 years ago by anonymous

Yes, you are right, beirdo. The problem is gone as of rev 27085. Thank you very much.

comment:4 Changed 9 years ago by beirdo

Resolution: Invalid
Status: infoneededclosed
Note: See TracTickets for help on using tickets.