Opened 9 years ago

Closed 9 years ago

#9208 closed defect (Duplicate)

0.24 fails to build on powerpc

Reported by: superm1@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

0.24 r27162. It fails to build on PowerPC. The same source builds fine on i386.

Here's a snippet of the failure:

ccache g++ -c -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -maltivec -maltivec -mabi=altivec -pthread -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -Wmissing-declarations -I/usr/include/freetype2 -D_REENTRANT -fPIC -D_GNU_SOURCE -DUSING_X11 -DUSING_XV -DUSING_XVMC -DUSING_XVMCW -DUSING_XVMC_VLD -DUSING_OPENGL -DUSING_OPENGL_VSYNC -DUSING_OPENGL_VIDEO -DUSING_MHEG -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_ALSA -DUSING_OSS -DUSING_V4L -DUSING_LINUX_FIREWIRE -DUSING_FIREWIRE -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr -I.. -I../.. -I../../external/FFmpeg -I. -I../libmyth -I../libmythdb -I../libmythhdhomerun -I../libmythdvdnav -I../libmythbluray -Idvbdev -Impeg -Iiptv -Ichannelscan -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/BasicUsageEnvironment -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/groupsock -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/liveMedia -I../libmythlivemedia/UsageEnvironment/include -I../libmythlivemedia/UsageEnvironment -I../libmythdb -I../libmythui -I/usr/include -I/usr/X11R6/include -I. -o nuppeldecoder.o nuppeldecoder.cpp
nuppeldecoder.cpp:31:19: fatal error: bswap.h: No such file or directory
compilation terminated.
make[4]: *** [nuppeldecoder.o] Error 1
make[4]: Leaving directory `/build/buildd/mythtv-0.24.0+fixes27162/mythtv/libs/libmythtv'
make[3]: *** [sub-libmythtv-make_default] Error 2
make[3]: Leaving directory `/build/buildd/mythtv-0.24.0+fixes27162/mythtv/libs'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/build/buildd/mythtv-0.24.0+fixes27162/mythtv'
make[1]: *** [override_dh_auto_install] Error 2
make[1]: Leaving directory `/build/buildd/mythtv-0.24.0+fixes27162'
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
******************************************************************************

Otherwise the full failure log is available at http://launchpadlibrarian.net/59002604/buildlog_ubuntu-natty-powerpc.mythtv_1:0.24.0%2Bfixes27162-0ubuntu1_FAILEDTOBUILD.txt.gz

Attachments (1)

bswap.h (662 bytes) - added by Kim Nguyen 9 years ago.
Missing bswap.h file

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Christian Marillat <marillat@…>

added for notification

comment:2 Changed 9 years ago by robertm

Owner: set to Janne Grunau
Status: newassigned

Changed 9 years ago by Kim Nguyen

Attachment: bswap.h added

Missing bswap.h file

comment:3 Changed 9 years ago by kim@…

Hi,

I managed to compile mythtv 0.24 (0.24.0+fixes.20101215.f0ffba1) by adding the custom bswap.h (attached to the bug) in mythtv/libs/libmythtv This file is a modified version of: mythtv/external/FFmpeg/libavutil/bswap.h

The sources then compile cleanly but I have not tested that nuppldecoder works.

Cheers.

comment:4 Changed 9 years ago by beirdo

This should be fixed in 933475ed53e76. This is now a duplicate of #9479

comment:5 Changed 9 years ago by beirdo

Resolution: Duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.