Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9215 closed defect (Invalid)

New OSD fails with xv-blit output

Reported by: anonymous Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I'm on Radeon HD 3200, KMS and xorg-edgers. So far I've been using xv-blit output without problems, today upgraded to 0.24-fixes. The new OSD doesn't properly scale to the screen dimensions (all video output done in 1080p); lots of controls are rendered too wide, y coords seem to be fine.

With opengl output the OSD looks fine, but I'm not getting video output, the image is stuck. I read somewhere that the opengl sync is (temporarily?) disabled.

Anyway I'm kinda disappointed by such regressions, this isn't a stable release to me.

Attachments (2)

mythfrontend.log (29.4 KB) - added by anonymous 7 years ago.
mythfrontend log when viewing a recording with the broken OSD on xvblit
myth-bad-osd-xv-blit2.jpg (19.8 KB) - added by anonymous 7 years ago.
screenshot when viewing a recording with the broken OSD on xvblit

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by anonymous

Do you honestly think we'd release if it wasn't working for everyone who bothered to test it during the last 4 months? Please keep your snide comments to yourself.

comment:2 Changed 7 years ago by markk

  • Owner set to markk
  • Status changed from new to accepted

Please attach the full, unabridged output of 'mythfrontend -v playback' and a screenshot of how the osd looks.

Changed 7 years ago by anonymous

mythfrontend log when viewing a recording with the broken OSD on xvblit

Changed 7 years ago by anonymous

screenshot when viewing a recording with the broken OSD on xvblit

comment:3 Changed 7 years ago by anonymous

You're right, my comment was out of line. I certainly appreciate your work. I have attached a screenshot and the fe log as requested. Please let me know if you need more information. The "video frames behind audio" messages in the log seem to be due to the screenshot procedure, so please ignore them.

comment:4 Changed 7 years ago by robertm

  • Status changed from accepted to infoneeded

What happens with Arclight? This appears to be a broken theme issue.

comment:5 Changed 7 years ago by stuartm

  • Resolution set to Invalid
  • Status changed from infoneeded to closed

The screenshot undoubtedly points to a broken theme. It's failing to include the area information necessary to allow the scaling required for XV and inheriting widgets from base.xml which is disallowed for osd.xml precisely because we need to constantly rescale. Please contact the themer directly as I'm sure they would be happy to correct their theme.

comment:6 Changed 7 years ago by anonymous

The problem does indeed not show up with Arclight, so it is theme specific (I used Abstract Blue). Thanks for your quick help and again apologies for jumping to conclusions. MythTV is a great piece of software!

comment:7 Changed 7 years ago by stuartm

  • Ticket locked set

Add Comment

Modify Ticket

Action
as closed The owner will remain markk.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.