Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9228 closed defect (Fixed)

OSD delete dialog leaves playback paused after pressing Esc

Reported by: John Veness <John.Veness.mythtv@…> Owned by: markk
Priority: trivial Milestone: 0.24.1
Component: MythTV - General Version: 0.24-fixes
Severity: low Keywords: delete dialog esc pause osd
Cc: Ticket locked: no

Description

When D is pressed while playing back a recording, the playback pauses while a dialog pops up asking whether the user wishes to delete the recording. If the user presses Esc at this point, the dialog disappears but the playback stays paused, with no OSD indication of paused state. The user has to press P to resume playback.

I think (although have no easy way of testing) that this is new in 0.24, that is, I think in earlier versions, pressing Esc would resume playback after dismissing the OSD dialog. This would certainly seem the logical thing to do in the case that the user pressed D accidentally.

$ mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version : 27204
MythTV Branch : branches/release-0-24-fixes
Network Protocol : 63
Library API : 0.24.20101028-1
QT Version : 4.7.0
Options compiled in:

linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by kenni

  • Owner set to markk
  • Status changed from new to assigned

I honestly don't know if this is considered a bug or if it is one of the intended changes introduced by the new MythUI OSD, but I've noticed this behaviour as well. Mark, feel free to kill it or unassign it.

comment:2 Changed 3 years ago by John Veness <John.Veness.mythtv@…>

If it is intended behaviour to stay paused after pressing Esc to dismiss the Delete dialog, then I suggest that the OSD paused indicator should appear. That way the user would know that he needs to unpause and doesn't just think it has hung.

However, I think it would be better to resume after pressing Esc.

comment:3 Changed 3 years ago by markk

(In [27254]) Unpause playback when clearing the Delete Recording OSD dialog (if we
paused it to show the dialog).

Refs #9228

comment:4 Changed 3 years ago by markk

  • Resolution set to Fixed
  • Status changed from assigned to closed

(In [27255]) Backport r27254 from trunk to release-0-24-fixes

Unpause playback when clearing the Delete Recording OSD dialog (if we
paused it to show the dialog).

Closes #9228

comment:5 Changed 3 years ago by markk

(In [27278]) Backport r27256 from trunk to release-0-24-fixes

Don't hold the OSD lock unnecessarily when processing editor keypresses.

Closes #9228

comment:6 Changed 3 years ago by beirdo

  • Milestone changed from unknown to 0.24.1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.