Opened 14 years ago

Closed 14 years ago

#925 closed defect (duplicate)

Backend segfault, gdb backtrace, SVN 8469

Reported by: Robert Kulagowski Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This happened overnight; no one was watching any programs at the time of the crash.

Last entry in mythbackend.log is:

2006-01-03 01:15:26.188 Scheduled 462 items in 12.9 = 3.95 match + 9.00 place
2006-01-03 01:17:47.585 Running HouseKeeping
2006-01-03 01:22:47.635 Running HouseKeeping
2006-01-03 01:27:47.662 Running HouseKeeping
2006-01-03 01:32:47.689 Running HouseKeeping

Backend crash:

[Thread -1383076944 (LWP 23379) exited]
[Thread -1392518224 (LWP 23359) exited]
[New Thread -1392518224 (LWP 23392)]
[Thread -1392518224 (LWP 23392) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1241072720 (LWP 22509)]
0xb6c75c35 in QChar::decomposition () from /usr/lib/libqt-mt.so.3

Thread 15 (Thread -1351615568 (LWP 22526)):
#0  0xb656fb61 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fce in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080a2941 in ProcessRequestThread::run (this=0x8110610) at mainserver.cpp:86
No locals.
#3  0xb68e0330 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 14 (Thread -1343226960 (LWP 22525)):
#0  0xb656fb61 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fce in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080a2941 in ProcessRequestThread::run (this=0x810fd58) at mainserver.cpp:86
No locals.
#3  0xb68e0330 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 13 (Thread -1334838352 (LWP 22524)):
#0  0xb656fb61 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fce in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080a2941 in ProcessRequestThread::run (this=0x8110f00) at mainserver.cpp:86
No locals.
#3  0xb68e0330 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 12 (Thread -1326449744 (LWP 22523)):
#0  0xb656fb61 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fce in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080a2941 in ProcessRequestThread::run (this=0x810b190) at mainserver.cpp:86
No locals.
#3  0xb68e0330 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 11 (Thread -1318061136 (LWP 22522)):
#0  0xb656fb61 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fce in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080a2941 in ProcessRequestThread::run (this=0x8117cc8) at mainserver.cpp:86
No locals.
#3  0xb68e0330 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 10 (Thread -1309672528 (LWP 22521)):
#0  0xb63d62ec in nanosleep () from /lib/tls/libc.so.6
No symbol table info available.
#1  0xb63d6110 in sleep () from /lib/tls/libc.so.6
No symbol table info available.
#2  0xb7a36a15 in JobQueue::ProcessQueue (this=0x81104a0) at jobqueue.cpp:475
        chanid = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae4a8e78, static shared_null = 0x80e3070}
        starttime = {d = {jd = 2453670}, t = {ds = 75540000}}
        startts = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae328ba0, static shared_null = 0x80e3070}
        type = 1
        id = 5819
        cmds = 0
        flags = 1
        status = 4
        hostname = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae5f87a8, static shared_null = 0x80e3070}
        sleepTime = 60
        jobStatus = {sh = 0x810fcc0}
        maxJobs = 1
        queueStartTimeStr = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae2743a0, static shared_null = 0x80e3070}
        queueEndTimeStr = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xabe80730, static shared_null = 0x80e3070}
        queueStartTime = 0
        queueEndTime = 2359
        curQTime = {ds = 3598611}
        curTime = 59
        message = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae4fe858, static shared_null = 0x80e3070}
        tmpStr = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0xae3200b8, static shared_null = 0x80e3070}
        jobs = {sh = 0x80fbff8}
        atMax = true
        inTimeWindow = true
        startedJobAlready = false
#3  0xb7a31e62 in JobQueue::RunQueueProcesser (this=0x81104a0) at jobqueue.cpp:138
No locals.
#4  0xb7a31e8b in JobQueue::QueueProcesserThread (param=0x81104a0) at jobqueue.cpp:144
        jobqueue = (class JobQueue *) 0x81104a0
#5  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#6  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 9 (Thread -1299792976 (LWP 22520)):
#0  0xb63d62ec in nanosleep () from /lib/tls/libc.so.6
No symbol table info available.
#1  0xb63d6110 in sleep () from /lib/tls/libc.so.6
No symbol table info available.
#2  0x08059eea in AutoExpire::Sleep (this=0x811c248, sleepTime=60) at autoexpire.cpp:280
        minSleep = 5
        timeExpended = 15
#3  0x08059e94 in AutoExpire::RunExpirer (this=0x811c248) at autoexpire.cpp:265
        curTime = {ds = 5552670}
        timer = {ds = 5552668}
#4  0x0805ceb5 in AutoExpire::ExpirerThread (param=0x811c248) at autoexpire.cpp:463
        expirer = (AutoExpire *) 0x811c248
#5  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#6  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 8 (Thread -1291404368 (LWP 22519)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39fad in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080acc07 in Scheduler::RunScheduler (this=0x811bc20) at scheduler.cpp:1096
        statuschanged = false
        recIter = {<std::_List_iterator_base> = {_M_node = 0xae64d348}, <No data fields>}
        prerollseconds = 0
        secsleft = 19572
        nexttv = (EncoderLink *) 0x8113888
        nextRecording = (ProgramInfo *) 0x85b40c0
        nextrectime = {d = {jd = 2453739}, t = {ds = 25140000}}
        curtime = {d = {jd = 2453739}, t = {ds = 5567489}}
        lastupdate = {d = {jd = 2453739}, t = {ds = 4512237}}
        recordfileprefix = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0x8112fa8, static shared_null = 0x80e3070}
        startIter = {<std::_List_iterator_base> = {_M_node = 0xae4e8c58}, <No data fields>}
        blockShutdown = false
        idleSince = {d = {jd = 0}, t = {ds = 0}}
        idleTimeoutSecs = 0
        idleWaitForRecordingTime = 15
        firstRun = false
        fillstart = {tv_sec = 1136272517, tv_usec = 190772}
        fillend = {tv_sec = 1136272526, tv_usec = 188344}
        matchTime = 3.95188904
        placeTime = 8.99757195
        query = {<> = {<No data fields>}, m_db = 0x810b2d0, m_isConnected = true, m_returnConnection = false}
#3  0x080b0795 in Scheduler::SchedulerThread (param=0x811bc20) at scheduler.cpp:1527
        sched = (Scheduler *) 0x811bc20
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 7 (Thread -1283015760 (LWP 22517)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39d7c in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb7c94354 in TVRec::RunTV (this=0x811a778) at tv_rec.cpp:1220
        lock = {mtx = 0x811a830}
        timeout = 118
#3  0xb7c93843 in TVRec::EventThread (param=0x811a778) at tv_rec.cpp:1065
        thetv = (class TVRec *) 0x811a778
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 6 (Thread -1274627152 (LWP 22515)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39d7c in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb7c94354 in TVRec::RunTV (this=0x8116e48) at tv_rec.cpp:1220
        lock = {mtx = 0x8116f00}
        timeout = 97
#3  0xb7c93843 in TVRec::EventThread (param=0x8116e48) at tv_rec.cpp:1065
        thetv = (class TVRec *) 0x8116e48
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 5 (Thread -1266238544 (LWP 22514)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39d7c in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb7c94354 in TVRec::RunTV (this=0x8115338) at tv_rec.cpp:1220
        lock = {mtx = 0x81153f0}
        timeout = 84
#3  0xb7c93843 in TVRec::EventThread (param=0x8115338) at tv_rec.cpp:1065
        thetv = (class TVRec *) 0x8115338
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 4 (Thread -1257849936 (LWP 22513)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39d7c in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb7c94354 in TVRec::RunTV (this=0x8113b98) at tv_rec.cpp:1220
        lock = {mtx = 0x8113c50}
        timeout = 106
#3  0xb7c93843 in TVRec::EventThread (param=0x8113b98) at tv_rec.cpp:1065
        thetv = (class TVRec *) 0x8113b98
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 3 (Thread -1249461328 (LWP 22512)):
#0  0xb656fdc2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
No symbol table info available.
#1  0xb6c39d7c in QWaitCondition::wait () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb7c94354 in TVRec::RunTV (this=0x810b308) at tv_rec.cpp:1220
        lock = {mtx = 0x810b3c0}
        timeout = 118
#3  0xb7c93843 in TVRec::EventThread (param=0x810b308) at tv_rec.cpp:1065
        thetv = (class TVRec *) 0x810b308
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 2 (Thread -1241072720 (LWP 22509)):
#0  0xb6c75c35 in QChar::decomposition () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#1  0xb6c75e47 in QString::arg () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0x080c29e6 in HouseKeeper::RunHouseKeeping (this=0x8109340) at housekeeper.cpp:244
        period = 1
        maxhr = 23
        minhr = 21
        dbTag = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0x863dbe8, static shared_null = 0x80e3070}
#3  0x080c3785 in HouseKeeper::doHouseKeepingThread (param=0x8109340) at housekeeper.cpp:330
        hkeeper = (HouseKeeper *) 0x8109340
#4  0xb656dccd in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0xb6415b0e in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 1 (Thread -1240426816 (LWP 22505)):
#0  0xb640df87 in select () from /lib/tls/libc.so.6
No symbol table info available.
#1  0xb688df28 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb6902ea2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb6902dcb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#4  0xb68e9305 in QApplication::exec () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#5  0x0807737a in main (argc=5, argv=0xbfe87b04) at main.cpp:559
        a = <incomplete type>
        binname = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0x80fc7b0, static shared_null = 0x80e3070}
        daemonize = false
        printsched = false
        testsched = false
        resched = false
        nosched = false
        nojobqueue = false
        noexpirer = false
        printexpire = false
        pidfs = <incomplete type>
        port = 6543
        statusport = 6544
        myip = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0x81099a8, static shared_null = 0x80e3070}
        masterip = {static null = {static null = <same as static member of an already seen type>, d = 0x80e3070,
    static shared_null = 0x80e3070}, d = 0x810a158, static shared_null = 0x80e3070}
        ismaster = true
        fatal_error = false
        runsched = true
#0  0xb6c75c35 in QChar::decomposition () from /usr/lib/libqt-mt.so.3

Change History (1)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Duplicate of #929 (root cause is memory corruption, most likely).

Note: See TracTickets for help on using tickets.