Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9273 closed Patch - Feature (Invalid)

DVB-S: Reusing a single "Input source" for multiple LNB connections causes incorrect DiSEqC commands to be created

Reported by: Per Lundberg <perlun@…> Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: 0.24
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hello,

One thing that caused me quite a lot of headache but eventually was sorted out was this:

I was trying to set up a DiSEqC-based setup, using one DVB-S card (TBS 8920), a DiSEqC switch and two LNB:s. Scanning for channels worked fine with both LNB:s, but *tuning* to a channel on the "second" LNB didn't work for some reason.

Alright, I gave it another try (after deleting the card/resetting the database or similar). This time, only the *second* LNB worked correctly, the first LNB didn't work at all. Likewise, scanning for channels worked - it was only the actual tuning that failed.

The hardware itself was working correctly with other programs (Kaffeine, hts-tvheadend).

Finally, I managed to locate and find the issue: it had to do with input sources. You absolutely *must* use one input source per LNB (as indicated by this web page: http://www.mythtv.org/wiki/DVB-S - the text there has been slightly clarified by me yesterday, after finally locating the problem).

If you (like I did) just create one input source for the whole DVB card, you get this very odd semantic that the scanning works, but tuning only works for one of your LNB:s.

I consider this a bug in the way MythTV builds up the DiSEqC commands. I saw the actual error in my backend logs while playing around with this: it sent the "port 2" command even for channels located on "port 1", when the input source was the same for both these channels.

Do you agree, can this be considered a bug?

Change History (4)

comment:1 Changed 9 years ago by danielk

Resolution: Invalid
Status: newclosed

While definitely non-ideal it is not a bug.

comment:2 Changed 9 years ago by Per Lundberg <perlun@…>

Resolution: Invalid
Status: closednew

Thanks Daniel. My suggestion is this:

We should change the "Input connections" setup to issue a warning/error (which one could be discussed) when you try to add a connection to an already existing input source.

Is there ever any reason why you would have two input connections on the same input source? If so, we could make the warning only be issued if the input source relates to a DVB(-S) source; I don't know how easy this is, but this would definitely be an improvement IMHO.

(Please, change the bug to be a "feature request" rather than a "bug" if you like. I don't have a patch ready for this right now.)

Right now, setting up DVB-S inside MythTV is unfortunately a lot more complex than it could be.

comment:3 Changed 9 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed
Type: Bug ReportPatch - Feature
Version: Unspecified0.24

As per the TicketHowTo, feature requests are not currently accepted on Trac. I'm marking this closed as an invalid patch ticket for now. If you do end up writing a patch for 0.24, re-open this ticket and attach it. Note that all of this current configuration code is likely to be rewritten prior to 0.25 due to TaskBrowserBasedSetup.

comment:4 Changed 9 years ago by anonymous

Alright, thanks for this. Let's hope we can make this work better in 0.25. I don't think there's much point in fixing it in 0.24 if the whole part will be updated in due time.

Note: See TracTickets for help on using tickets.