Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 2 years ago

#9277 closed Bug Report (Fixed)

Teletext subtitles not automatically showing

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I installed 0.24 last night and the Teletext Subtitles are not showing automatically on LiveTV, I have them enabled in settings.
To have them show i have to turn them off and then turn them on again.
I have MythTV version 27315.

Attachments (1)

playback.txt (49.6 KB) - added by andreasbrannstrom@… 3 years ago.
My mythfrontend -v playback output

Download all attachments as: .zip

Change History (17)

comment:1 Changed 3 years ago by markk

  • Owner set to markk
  • Status changed from new to accepted

Please attach the full output of mythfrontend -v playback

I've just tested here and it works fine.

Changed 3 years ago by andreasbrannstrom@…

My mythfrontend -v playback output

comment:2 Changed 3 years ago by markk

Can you post a clip from one of those channels somewhere? Around 60 seconds worth should be fine.

The source has multiple teletext menu streams which may be confusing some of the new automatic menu/caption detection.

Thanks

comment:3 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.24.1

comment:4 Changed 3 years ago by anonymous

You can download a clip from this adress:
http://sprend.com/download.jsp?FileId=CNRgTCZXSBpyaNJctiDD

The file is 45,9 MB and it will be available until 2010-12-08.

comment:5 Changed 3 years ago by markk

"The file has already been deleted." - probably easier to just use http://filebin.ca/

comment:6 Changed 3 years ago by anonymous

comment:7 Changed 3 years ago by markk

  • Status changed from accepted to infoneeded

This should be fixed in both trunk and release-0-24-fixes. Can you confirm?

comment:8 Changed 3 years ago by andreasbrannstrom@…

I upgraded to latest 0-24-fixes and changed to a channel with teletext subtitles and it worked.
Then changed to another channel with subtitles and it didnt work.
Then changed to channel without subtitles and then back to an channel with it and it worked again.
Tried this a few times and it doesnt work if i change channels between two channels with subtitles.

comment:9 Changed 3 years ago by markk

  • Status changed from infoneeded to assigned

comment:10 Changed 3 years ago by markk

  • Milestone changed from 0.24.1 to 0.24.2
  • Status changed from assigned to accepted

comment:11 Changed 3 years ago by Github

Subtitles: Fix an error in subtitle enumeration logic.

Fixes the re-enablement of subtitles after a teletext menu has been
displayed.

Also refs #9277

Branch: master
Changeset: d2cc12f021fe0ed1186ce9f345a71667f9a4e903

comment:12 Changed 2 years ago by markk

  • Milestone changed from 0.24.2 to 0.25

comment:13 Changed 2 years ago by markk

  • Owner markk deleted
  • Status changed from accepted to assigned

comment:14 Changed 2 years ago by danielk

  • Owner set to danielk

comment:15 Changed 2 years ago by Github

Refs #9277. Adds some closed caption and subtitle caption track debugging.

Branch: master
Changeset: e2f74e9a966484cf8beecdd545e989183ef7135a

comment:16 Changed 2 years ago by danielk

  • Resolution set to Fixed
  • Status changed from assigned to closed

I could not download the attached sample, but I tested with another sample and it appears the logic is functioning as intended in trunk. It is possible that we are simply selecting a different subtitle or teletext caption language than intended, or we are trying to select the stream too early. I've added some debugging so that if this is still a problem a -v playback log will tell us which subtitle or teletext stream is being selected at startup and tell us if we try to enable them and can't find them.

I'm closing this as 'fixed' but please reopen if with a new sample and -v playback log if the problem is still occurring for you.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.