Opened 9 years ago

Closed 9 years ago

#9299 closed Bug Report (Invalid)

mythfrontend hangs on exit

Reported by: michael_zanetti@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24
Severity: medium Keywords:
Cc: Ticket locked: no

Description

On both of my two frontend machines I cannot exit the frontend. When I exit the frontend, the frontend itself closes, but the process still sits there around forever.

The attached log contains the last 20 lines of "mythfrontend -v all" after I exited the frontend.

On one machine I use mythwelcome. If I exit the frontend there, mythwelcome doesn't repaint itself because it thinks the frontend would be still running. The screen still shows the "confirm exit" dialog not reacting to anything. To be able to see mythwelcome again, I have to "killall mythfrontend".

On the second machine, I use ~/.xinitrc to start the frontend in an infinite loop with "pm-suspend" so that the machine goes into suspend once the frontend has exited. However, because of this issue this will never happen until I manually kill the frontend. When I exit the frontend, the screen goes black and shows the X-cursor forever waiting for the mythfrontend process to exit. Once I kill the frontend, the machine goes to suspend and the frontend restarts on wakeup.

According to the debug output, everything is shut down correctly. The last thing happening is mythsocketthread exiting from run().

This is the output of "ps -C mythfrontend -m" after waiting at least 30 seconds after exiting the frontend:

  PID TTY          TIME CMD                                                                                                                                                      
 9367 ?        00:00:26 mythfrontend                                                                                                                                             
    - -        00:00:26 - 

I have seen this problem already with 0.23-fixes. At that time it happened only every once in a while. Now with 0.24, it happens every time I exit the frontend. As a workaround, I have added the "Shutdown" option to the exit menut and have set up "killall mythfrontend" as the shutdown command in the frontend. This seems to do the job, but of course is not the solution. Let me know if you need additional informations about my systems.

Attachments (1)

mythfrontend-exit.log (3.5 KB) - added by michael_zanetti@… 9 years ago.
frontend log when hung on exit

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by michael_zanetti@…

Attachment: mythfrontend-exit.log added

frontend log when hung on exit

comment:1 Changed 9 years ago by michael_zanetti@…

Btw. I have also installed a frontend on my laptop for testing. I can use it just like the others with the same backend, the same theme and most other options set to the same. On this machine I cannot reproduce this issue. However, I remember having it seen also at 0.23 times once in a while when I did some theme-development. As it didn't happen really often at that time, I didn't open a bugreport back then.

comment:2 Changed 9 years ago by paulh

Can you please check you haven't got any old plugins installed like MythMovies? this has been known to cause the symptoms you are seeing.

comment:3 Changed 9 years ago by anonymous

Ok, after removing all myth* packages, deleting /usr/share/mythtv and reinstalling mythtv it works again.

I'm sorry for the noise.

comment:4 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed
Note: See TracTickets for help on using tickets.