Opened 9 years ago

Closed 8 years ago

#9346 closed Bug Report (Invalid)

After upgrade to 0.24, DLNA discovery to my Playstation 3 no longer works correctly

Reported by: jstevens@… Owned by: beirdo
Priority: minor Milestone: unknown
Component: MythTV - UPnP Version: 0.24
Severity: low Keywords: DLNA PS3
Cc: Ticket locked: no

Description

After upgrading to 0.24, if I turn my Playstation 3 off and then on, it is unable to see the MythTV DLNA server unless I restart mythbackend. I haven't made any hardware or network changes, and downgrading to 0.23.1 solves the issue.

I will attach any logs that are needed when I can. I currently have logging set to "important, general, upnp".

Attachments (1)

mythbackend.log.txt (12.8 KB) - added by jstevens@… 9 years ago.
mythbackend.log of startup (PS3 on 192.168.0.242)

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by jstevens@…

Attachment: mythbackend.log.txt added

mythbackend.log of startup (PS3 on 192.168.0.242)

comment:1 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

comment:2 Changed 9 years ago by beirdo

Owner: changed from dblain to beirdo

comment:3 Changed 9 years ago by beirdo

Status: assignedinfoneeded

It seems that your posted log shows the PS3 talking to mythbackend just fine. I have no troubles here with my UPnP clients, so maybe you just need to wait a touch after turning on the PS3 for the UPnP discovery to happen?

If you could get me logs when the PS3 is not seeing the backend at all, that would be good.

comment:4 Changed 9 years ago by jstevens@…

Well the problem is that there are no logs when the PS3 doesn't see the backend, because it seems to pretend it's not there, or there is no discovery process that is in the log. The log I attached is what the PS3 sends when I restart the backend, which I hoped would give some kind of help.

I have discovered since opening this ticket that the PS3 will eventually find the MythTV media server, but that takes over an hour or more (it seems to be random) before Myth and the PS3 discover each other again. As it is, if the PS3 is off and then you turn it back on, it won't see the media server, and scanning for it through the PS3 doesn't pull it back either. I have to restart the backend before it's seen immediately.

The DLNA improvements are great, as it's nice to see a date and time attached to the recordings now. I'm just wondering what else changed that has the PS3 so picky now.

I will do more searching in the logs and attach any more info that I can.

comment:5 Changed 9 years ago by jstevens@…

Sorry for the delay, holidays and all that.

I've tried some different things, but there isn't any logs I can attach as the PS3 and Myth backend do not communicate with each other until something happens to trigger a search for a DNLA server, which seems to happen sometimes when we turn on a Windows 7 machine. When Myth backend broadcasts to that machine, the PS3 will pick up.

I will do more testing and get back to you, but I wanted to keep this ticket updated.

comment:6 Changed 9 years ago by stuartm

Milestone: 0.25
Status: infoneededassigned

comment:7 Changed 8 years ago by jstevens@…

This ticket can be closed. I don't know why my firewall started getting picky about it (especially how many times I've turned it off), but when I disabled gShield the Playstation 3 saw the backend immediately.

You can mark this ticket user error and close. Thanks for the help though!

comment:8 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.25unknown
Resolution: Invalid
Status: assignedclosed

Thanks for reporting back.

Note: See TracTickets for help on using tickets.