Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9359 closed Bug Report (Fixed)

0.24 Cutlist Editor Unstable

Reported by: Ben Klein <bklein1@…> Owned by: sphery
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

This is my first bug report. I have tried to follow all the rules but apologies if I have missed something.

This problem seems similar to these bug reports, which have been closed -

9218, 9234

Problem -

Frontend freezes when editing cutlist and has to be killed with cli (killall mythfrontend). Can ctrl-z and change skip amount without freezing, but freeze occurs as soon as I right/ left arrow to skip.

Problem occurs on SD recordigs (haven't tried HD) and not limited to a specific channel nor OSD theme.

To reproduce - As above.

Other - Backend log doesn't seem to show anything relevant.

I am using this version of myth on a combined frontend and backend with nvidia 8600gt 256mb graphics -

Running arch linux (just started using it, previously ubuntu 10.04) -

[ben@htpc ~]$ uname -r 2.6.36-ARCH

Attachments (1)

version_info (732 bytes) - added by Raymond Wagner 9 years ago.
attaching as a file, as the text says to

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Raymond Wagner

Description: modified (diff)

Changed 9 years ago by Raymond Wagner

Attachment: version_info added

attaching as a file, as the text says to

comment:2 Changed 9 years ago by beirdo

Owner: set to sphery
Status: newassigned

comment:3 Changed 9 years ago by beirdo

Owner: changed from sphery to sphery

comment:4 Changed 9 years ago by sphery

There have been many changes in the player code that may have fixed issues with freezing while editing recordings. Please try again with current 0.24-fixes and/or current unstable/development MythTV , and if you find the issue is fixed, please let us know.

If you still encounter freezes, please get a backtrace (with debug symbols) of the frozen mythfrontend process as described at http://www.mythtv.org/wiki/Debugging and http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2 . (Run mythfrontend under gdb with -v playback, interrupt with Ctrl+C once it freezes, and then retrieve a backtrace as described.) Then, please attach the backtrace, the mythfrontend log, and specify actual git SHA or time of git clone/pull, since your --version information is lacking the information.

Thanks.

comment:5 Changed 9 years ago by sphery

Status: assignedinfoneeded

comment:6 Changed 9 years ago by bklein1@…

Thanks. I tried 0.24-fixes and it solved the cutlist editor problem.

comment:7 Changed 9 years ago by sphery

Resolution: Fixed
Status: infoneededclosed

Fixed by some of Mark K's many fixes.

Thanks for the quick response, Ben.

comment:8 Changed 9 years ago by J.Pilk@…

I haven't seen this 'instability' but some recordings still give trouble in my current 0.24-fixes if the edit point goes to or beyond eof; the step-size gets confused. Workaround is to quit edit mode and resume, then work *forwards* to the desired endpoint. May perhaps have been fixed by https://github.com/MythTV/mythtv/commit/32839c314; I haven't seen the effects of that yet.

Note: See TracTickets for help on using tickets.