Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#9373 closed Bug Report (Fixed)

DVB-S subtitles not showing

Reported by: Yoav Dvir <yoav@…> Owned by: janne
Priority: minor Milestone:
Component: MythTV - Video Playback Version: 0.24
Severity: medium Keywords:
Cc: markk Ticket locked: no

Description

I am running mythtv-0.24 on channels coming from DVB-S source (Yes/ Amos 4W). The channels playback OK, however I cannot see the subtitles in any of the channels I watch.

I can see the subtitles with other players (i.e. VLC) as well as on the latest FFMPEG revision, when I play the stream recorded by Myth. Also I can see in the log that Myth correctly identifies the available subtitles streams, however as said I can get nothing to display on the OSD.

I tried switching subtitles channel (both from the menu and by pressing 't'), changing the OSD font to a hebrew one, playing with the OSD encoding, but nothing helps.

Attached is a short clip recorded by myth demonstrating the problem.

Also please look at http://www.gossamer-threads.com/lists/mythtv/users/463476 for some correspondence on the issue.

Attachments (2)

mythfrontend_-v_most.log (97.5 KB) - added by Yoav Dvir <yoav@…> 3 years ago.
mythfrontend-v-most-doronr.log.zip (61.3 KB) - added by Doron Rabia <doronr29@…> 3 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 3 years ago by markk

  • Cc markk added

I didn't realise my last reply to that thread was private. For clarity, the root of the problem is:-

Hold that thought - the mythtv ffmpeg version is up to date for DVB
subs. The problem is libavformat/mpeg.ts is highly customised for
mythtv and some of the more recent ffmpeg dvb sub code is disabled -
hence this actually looks like a mythtv problem.

Changed 3 years ago by Yoav Dvir <yoav@…>

comment:2 Changed 3 years ago by robertm

  • Component changed from MythTV - DVB to MythTV - Video Playback
  • Status changed from new to infoneeded_new

Can you test this against current master? If not, can you please provide a sample recording showing the issue?

Changed 3 years ago by Doron Rabia <doronr29@…>

comment:3 Changed 3 years ago by Doron Rabia <doronr29@…>

Hi robertm.

I seem to have the same issue as Yoav.
I have updated to the latest build of 0.24.1 (fixes/0.24 [v0.24.1-10-g4dec7cf]) but still get no subtitles.
I have attached a relevant log file.

BTW - this was also the case with 0.23 and 0.23.1 .

TIA,

Doron.

comment:4 follow-up: Changed 3 years ago by robertm

Again, we need a test against current master or a sample recording, please.

comment:5 in reply to: ↑ 4 Changed 3 years ago by Doron Rabia <doronr29@…>

Replying to robertm:

Again, we need a test against current master or a sample recording, please.

Pardon my ignorance but - by sample recording do you mean attaching a recorded output of the a channel that does not show subtitles ?
Sorry I am not familiar with current master. I will look it up and get back with a better answer.

Thanks,

Doron.

comment:6 follow-up: Changed 3 years ago by robertm

Yes, we would need a ~50-100 MB recording file that shows the issue (ie, some other linux app plays the subtitles and myth does not), and current master means the current revision of our development branch.

comment:7 in reply to: ↑ 6 Changed 3 years ago by Doron Rabia <doronr29@…>

Replying to robertm:

Yes, we would need a ~50-100 MB recording file that shows the issue (ie, some other linux app plays the subtitles and myth does not), and current master means the current revision of our development branch.

Thanks for your reply.
I have uploaded a 56MB sample here : http://www.megaupload.com/?d=RTYJA0EG

Subtitles are displayed by vlc on the same mythtv server that does not display them using mythfrontend UI.

Thanks for your time,

Doron.

comment:8 Changed 3 years ago by Doron Rabia <doronr29@…>

comment:9 Changed 3 years ago by Github

DVB Subtitles: Fix display of subs with no display segment.

The DVB subtitle standard reads:

'Within a display set the sequence of segments (when present) is:

  • page composition;
  • region composition;
  • CLUT definition;
  • object data;
  • end of display segment;'

In the samples provided in #9373, the end of display segment is not
seen. The 'when present' above suggests that it is not required but the
ffmpeg code assumes it is. The workaround is to check that the previous
4 segments have been seen and, if so, process a dummy display segment.

mplayer and ffplay both appear to have the same problem.

Refs #9373

Branch: master
Changeset: d27bedf5571bdb80c164ce5d11a8af55f0275b92

comment:10 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.24.2
  • Resolution set to Fixed
  • Status changed from infoneeded_new to closed

comment:11 Changed 3 years ago by doronr29@…

Thank you so much for the fix :)
I will test it ASAP.

comment:12 Changed 3 years ago by doronr29@…

Confirmed to work :):) - thanks a lot , this has been long awaited for and is well appreciated.

comment:13 Changed 2 years ago by stuartm

  • Milestone 0.24.2 deleted

Milestone 0.24.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.