Opened 9 years ago

Closed 9 years ago

#9377 closed Bug Report (Invalid)

mytharchive create DVD fails using projectx wth subtitles

Reported by: Larry Johnson <keepitsimpleengineer@…> Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythArchive Version: 0.24-fixes
Severity: medium Keywords: dvd iso subtitle projectx chmod
Cc: Ticket locked: no

Description

When creating a DVD iso from two recordings with cutlists and subtitles selected, mytharchive failed. From mythburn.log

renameProjectXFiles start -----------------------------------------
chmod: changing permissions of `/home/mytharchive/temp/': Operation not permitted
------------------------------------------------------------

Attachments (9)

progress.log (4.0 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
mythburn.log.tar.gz (69.8 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
mythburn.log compressed
directory-mytharchive-temp-2.tar.gz (883 bytes) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
contents of temp/2 directory compressed
Screenshot-MytharchiveSettings(2).jpg (60.4 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
mythfrontend -version.txt (774 bytes) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
Directory-listings-mytharchive.txt (2.2 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
newfile2_log.txt (2.5 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
Screenshot-MythTV Frontend-1062_20101104040000.jpg (43.3 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.
ffmpeg-i-1062_20101104040000.mpg.log (5.5 KB) - added by Larry Johnson <keepitsimpleengineer@…> 9 years ago.

Download all attachments as: .zip

Change History (24)

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: progress.log added

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: mythburn.log.tar.gz added

mythburn.log compressed

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

contents of temp/2 directory compressed

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: mythfrontend -version.txt added

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

comment:1 Changed 9 years ago by paulh

Do you still have the file newfile2_log.txt available? There appears to be something wrong with the parsing of ProjectX log file to get the file names.

comment:2 Changed 9 years ago by paulh

Status: newinfoneeded_new

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Attachment: newfile2_log.txt added

comment:3 in reply to:  1 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to paulh:

Do you still have the file newfile2_log.txt available? There appears to be something wrong with the parsing of ProjectX log file to get the file names.

Attached.

comment:4 Changed 9 years ago by J.Pilk@…

For starters:

2010-12-14 11:27:32 Didn't find any subtitle elements in stream info file.

comment:5 in reply to:  4 ; Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to J.Pilk@…:

For starters:

2010-12-14 11:27:32 Didn't find any subtitle elements in stream info file.

Subtitles are in the original recording and show up in cutlist viewing, see attached screenshot Screenshot-MythTV Frontend-1062_20101104040000.jpg

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

comment:6 in reply to:  5 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to Larry Johnson <keepitsimpleengineer@…>:

Replying to J.Pilk@…:

For starters:

2010-12-14 11:27:32 Didn't find any subtitle elements in stream info file.

Subtitles are in the original recording and show up in cutlist viewing, see attached screenshot Screenshot-MythTV Frontend-1062_20101104040000.jpg

So I uploaded the 1062_20101104040000.mpg file to my workstation and ran ProjectX(0.90.4.00b32⋯2009-08-23). ProjectX reported "Teletext: n/a" which matched what the htpc/ProjectX reported.

When I view the file on Mythtv htpc or the remote client on the workstation, the subtitles are present. I have no idea why this is.

Should this be another bug report?

comment:7 Changed 9 years ago by J.Pilk@…

I'm afraid I don't know enough about how subtitles are encoded to say what's happening, but my advice for MythArchive? is to take to heart the philosophy of your email address and do everything you possibly can _outside_ MythArchive?. Otherwise you'll process for hours and quite often crash out with an unhelpful error report and no obvious way of picking up the pieces. Usually the report just notes a failure. I tried to alter this situation in the patch I submitted some time ago, but that wasn't created with a version control tool and adapting it for 0.24 looks as if it will take some effort.

comment:8 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

I ran ffmpeg -i on the original recording after uploading it to another computer (mythtv client, ubuntu 10.10). The result is attached.

Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

comment:9 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: infoneeded_newassigned
Version: Unspecified0.24-fixes

comment:10 Changed 9 years ago by J.Pilk@…

I don't recognise all the ffmpeg preamble but it does look as if it's only finding two streams. Are your subtitles really separately encoded, so that you can enable/disable them, or are they just part of the picture - ie, overlaid at source? I wouldn't expect MythArchive? to crash just because it didn't find a subtitle stream, anyway. I do wonder if ProjectX is applying a 0.24 cutlist as if it was 0.23; I'm finding some confusion about the initial cut-out and cut-in.

comment:11 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Looking at the progress log:

2010-12-14 10:48:24 ffmpeg -threads 2 -v 1 -i "/pvr/mythtv/recordings/1062_20101104040000.mpg" -r ntsc -target dvd -b 4771k -s 720x480 -acodec copy -copyts -aspect 4:3 "/home/mytharchive/temp/work/1/newfile2.mpg" -map 0:0 -map 0:1

Which processes the recording. Shouldn't it have the option "-scodec copy" to force subtitle copy stream?

comment:12 Changed 9 years ago by J.Pilk@…

As I suggested in Comment 10, the ProjectX output is from a few GOPs at the start of the recording and a few at the end - presumably not what was intended; so the translation from Myth cutlist to ProjectX cutlist needs to be revised in Mythburn.py, too. mythcutprojectx uses bytecount positions, mythburn.py uses frame counts. I had one pathological recording where the bytecount approach worked and the framecount didn't, but it may be that framecount is usually more precise. It seems to me that the bytecount algorithm ought to cut only at keyframes, but in practice I get the impression that it's finer-grained than that. Could be, of course, that the commercial breaks are also tied to keyframes, but the Myth editor doesn't suggest that. It probably varies from one edit desk to another, anyway - not to mention international differences.

This looks to be a separate issue from the elusive subtitle stream.

comment:13 in reply to:  12 Changed 9 years ago by Larry Johnson <keepitsimpleengineer@…>

Replying to J.Pilk@…:

As I suggested in Comment 10, the ProjectX output is from a few GOPs at the start of the recording and a few at the end - presumably not what was intended; so the translation from Myth cutlist to ProjectX cutlist needs to be revised in Mythburn.py, too. mythcutprojectx uses bytecount positions, mythburn.py uses frame counts. I had one pathological recording where the bytecount approach worked and the framecount didn't, but it may be that framecount is usually more precise. It seems to me that the bytecount algorithm ought to cut only at keyframes, but in practice I get the impression that it's finer-grained than that. Could be, of course, that the commercial breaks are also tied to keyframes, but the Myth editor doesn't suggest that. It probably varies from one edit desk to another, anyway - not to mention international differences.

This looks to be a separate issue from the elusive subtitle stream.

Alas. A check of the recordedprogram record for this recorded program indicates that the program has closedcaption but not subtitles. Apparently mytharchive does not support closedcaption but does support subtitles (teletext). I'm looking at ccextractor.

comment:14 Changed 9 years ago by J.Pilk@…

I've opened a new ticket, #9389, to deal with the cutlist translation change; and looking at the bytecount script again has reminded me that it works with offsets from the keyframe, not the keyframe itself, so my misgivings above are probably unfounded. Bytecount is probably more robust, and just as precise.

comment:15 Changed 9 years ago by paulh

Resolution: Invalid
Status: assignedclosed

MythArchive? doesn't support closed captions. Changes to the way the cut list is saved in the DB has broken removing the cut list but that has a separate ticket.

Note: See TracTickets for help on using tickets.