Opened 9 years ago

Closed 9 years ago

#9460 closed Patch - Bug Fix (Invalid)

[patch] OpenGL doublelock fix

Reported by: Jiri Fojtasek <jiri.fojtasek@…> Owned by: Janne Grunau
Priority: major Milestone: unknown
Component: MythTV - Video Playback Version: Unspecified
Severity: high Keywords:
Cc: Ticket locked: no

Description

This patch fixing ocasional frontend crash and video stuck during DVB-S live tv playback when using hardware deinterlacer (detailed log included).

I using Radeon X1300 with oss drivers. In order to fix this issue i tried update mesa classic to galium but without success.

The problem is than "OpenGLLocker ctx_lock(gl_context)" was issued two times in the same context in functions:

VideoOutputOpenGL::SetupDeinterlace?

OpenGLVideo::AddDeinterlacer?

This also fixed ocasional log messages "VidOutGL: Couldn't load deinterlace filter" whish was related to this problem. The fix is valid for trunk and 0.24-fixes. This fix may be related to #9216 #9272

Jiri

Attachments (2)

102-opengl_doublelock_fix.patch (479 bytes) - added by Jiri Fojtasek <jiri.fojtasek@…> 9 years ago.
the patch
crash.log (6.2 KB) - added by Jiri Fojtasek <jiri.fojtasek@…> 9 years ago.
the log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Jiri Fojtasek <jiri.fojtasek@…>

the patch

Changed 9 years ago by Jiri Fojtasek <jiri.fojtasek@…>

Attachment: crash.log added

the log

comment:1 Changed 9 years ago by Jiri Fojtasek <jiri.fojtasek@…>

This patch is invalid since we use recursive qmutex. The problem must be hidden somewhere else, so please close this ticket.

Jiri

comment:2 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: unknown
Resolution: Invalid
Status: newclosed

Closed by request from reporter.

Note: See TracTickets for help on using tickets.