Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9570 closed Bug Report (Fixed)

Position bar broken with DVB-T radio

Reported by: John Veness <John.Veness.mythtv@…> Owned by:
Priority: minor Milestone: 0.24.1
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by wagnerrp)

When playing back a UK DVB-T radio program, i.e. ones with audio and MHEG-only, no video, the position bar (that you see when you press I, or when you seek forwards or backwards using the cursor keys) does not work properly. Specifically, it shows the length of the program OK, but the position is always 0:00:00 no matter where you actually are in the program.

It seems that seeking through the program does actually work, even if the position bar does not correctly show the position. If I press E then the position looks OK (although obviously it pauses playback so is not ideal).

The problem occurs when playing back both newly recorded DVB-T radio programs, and playing back older DVB-T radio programs that used to have a correct position bar when playing, so I don't think the problem is with the recording, but with the playback. Nonetheless, if it helps, I can provide a sample DVB-T radio recording.

This problem started with an update that I installed on the weekend, either 5 or 6 Feb 2011. I use Ubuntu 10.10 and update daily with mythbuntu 0.24-fixes autobuilds.

The first version that I am aware of that had the problem was:

MythTV Version   : v0.24-151-g1a69c92
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20101129-1
QT Version       : 4.7.0

but it still happens in the latest version:

MythTV Version   : v0.24-153-g6318d52
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20101129-1
QT Version       : 4.7.0

The position bar works correctly with DVB-T audio/video programs.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by tralph

  • Milestone changed from unknown to 0.24.1
  • Resolution set to Fixed
  • Status changed from new to closed

This should be fixed by 4e815b0aa049f99caa1a and 0ddc3f2678a052d216ed.

comment:2 Changed 3 years ago by Taylor Ralph

Fix duration/position information for MHEG and audio only playback.

Refs #9570.

Changeset: 4e815b0aa049f99caa1a6b5d78b481d314f130cc

comment:3 Changed 3 years ago by Taylor Ralph

Only need a video track for duration/position info so remove MHEG check.

Refs #9570.

Changeset: 98286fe22b363e1b37a5210eb62cb2858e01e0fb

comment:4 Changed 3 years ago by wagnerrp

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.