Opened 10 years ago

Closed 9 years ago

#9576 closed Bug Report (Fixed)

No active or passive EIT unless recording

Reported by: steltek@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythTV does not collect EIT data on one particular transponder unless I schedule a recording on it. (Neither active EIT nor passive LiveTV collection seem to work.) This may or may not be related: One of the channels on the transponder switched from Free-to-air to PayTV beginning 2011 and is now encrypted (I can't watch it) but the other's are still free. I can't really verify but I have a suspicion that that is when my EIT collection stopped working.

DVB-S receiver: Terratec Cinergy S2 USB HD (similar to TeVii? S660, ds3000/dw2102) MythTV version: 0.24+fixes20110203-0.0 (Christian Marillat repository) Linux: Debian wheezy/testing

Affected transponder: MTV Germany Encrypted Channel: MTV Germany Free-to-air Channel: VIVA Germany

I'm attaching chandata.txt with data from my SQL DB on the channels, transponder and DVB card setup, and also mythbackend.log with EIT debugging enabled. You can see me tuning to VIVA Germany (channel 30676 in the logs) at 2011-02-12 22:09:53.831 until 2011-02-12 22:12:45.606. My test recording starts at 2011-02-12 22:15:05.596 and you can see the EITHelper adding events soon afterwards.

Attachments (2)

mythbackend.log (196.2 KB) - added by steltek@… 10 years ago.
chandata.txt (10.9 KB) - added by steltek@… 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by steltek@…

Attachment: mythbackend.log added

Changed 10 years ago by steltek@…

Attachment: chandata.txt added

comment:1 Changed 10 years ago by steltek@…

P.S. My card does throw a lot of DVB stream errors (and generates quite a bit of artifacts), which you will see in the log. It seems to be a driver issue (I cannot reproduce the problem when hooking it up to Windows), but that shouldn't affect the EIT collection as it seems to work for all other transponders and when recording. It's just the active EIT scan and LiveTV EIT collection that don't work.

comment:2 Changed 10 years ago by steltek@…

Update: I found out that I had 'quick tuning' set on my receiver and that this setting prevents passive EIT from working in LiveTV. After removing that setting, LiveTV now does collect passive EIT.

Active EIT collection still does not work though. Here's an extract from the log which I believe is MythTV attempting to do active EIT collection:

2011-02-26 02:25:47.626 EITScanner (1): Now looking for EIT data on multiplex of channel 28671
2011-02-26 02:25:47.664 EITCache: Pruning all entries that ended before UTC 2011-02-25T02:31:07
2011-02-26 02:25:48.742 EITCache: Deleting old cache entries from the database
2011-02-26 02:25:51.815 PID 0xfac status: Encrypted
2011-02-26 02:25:55.138 PID 0xfab status: Encrypted
2011-02-26 02:31:15.107 EITScanner (1): Now looking for EIT data on multiplex of channel 4911

comment:3 Changed 10 years ago by steltek@…

Update 2: As a test, I deleted all the channels 'in front of' the one I actually use, so I removed channels 28671, 28673, 28674 and 28675 from the database. Active EIT now seems to pick up data properly.

I guess when the first channel on a transponder is not tuneable, active EIT does not work. (It won't try subsequent channels.) Might be useful to add a 'EIT chan' field to the DTV Multiplex and then have the EIT scanner walk the channels on a transponder and note the last successful one in there for future scans (when it fails or is empty, walk all the channels again).

comment:4 Changed 9 years ago by robertm

Resolution: Fixed
Status: newclosed

Based on the last comment to this ticket, this should now be fixed in master after 19a2cc7c3661675faa8f.

Note: See TracTickets for help on using tickets.