Opened 10 years ago

Closed 9 years ago

#9643 closed Bug Report - General (Fixed)

issue with canceling scheduled recording while watching LiveTV

Reported by: voyo <voyo.myth@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.24-fixes
Severity: low Keywords: canceling recording
Cc: voyo.myth@… Ticket locked: no

Description (last modified by sphery)

When watching live TV, scheduled program to record cannot be canceled (and keep going to watch live TV). Related option is enabled to allow this in config. (dialog box does appear on screen). WAF is dropping down hardly because of this :-/ backend is getting "Received: CANCEL_NEXT_RECORDING 1" after manual cancelation with dialog box on screen. Below detailed logs. BTW, in those logs national chars are missing in program names.

2011-03-08 21:55:38.038 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(15714) desired(15710)
2011-03-08 21:55:39.739 Finished recording WIELKIE KONSTRUKCJE: WIEOWIEC W BAHRAJNIE: channel 16710
2011-03-08 21:55:39.746 LoadFromScheduler(): Error, called from backend.
2011-03-08 21:55:39.759 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 14 min
2011-03-08 21:55:39.783 Finished recording WIELKIE KONSTRUKCJE: WIEOWIEC W BAHRAJNIE: channel 16710
2011-03-08 21:55:41.007 RecBase(34:/dev/dvb/adapter2/frontend0): GetKeyframePositions(19,9223372036854775807,#0) out of 2
2011-03-08 21:55:41.312 RecBase(34:/dev/dvb/adapter2/frontend0): GetKeyframePositions(19,9223372036854775807,#1) out of 3
2011-03-08 21:58:29.084 Expiring 0 MB for 16710 at 2011-03-08T21:55:36 => "WIELKIE KONSTRUKCJE: WIEOWIEC W BAHRAJNIE"
2011-03-08 21:58:30.056 Reschedule requested for id 0.
2011-03-08 21:58:30.294 LoadFromScheduler(): Error, called from backend.
2011-03-08 21:58:30.316 Scheduled 39 items in 0.2 = 0.00 match + 0.25 place
2011-03-08 21:59:29.918 TVRec(32): ASK_RECORDING 32 29 0 0
2011-03-08 21:59:29.921 TVRec(30): ASK_RECORDING 30 29 0 0
2011-03-08 21:59:29.921 TVRec(33): ASK_RECORDING 33 29 0 0
2011-03-08 21:59:29.921 TVRec(31): ASK_RECORDING 31 29 0 0
2011-03-08 21:59:29.947 TVRec(25): ASK_RECORDING 25 29 0 0
2011-03-08 21:59:30.101 TVRec(34): ASK_RECORDING 34 29 0 0
2011-03-08 21:59:41.614 Received: CANCEL_NEXT_RECORDING 1
2011-03-08 22:00:00.125 LoadFromScheduler(): Error, called from backend.
2011-03-08 22:00:00.150 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 14 min
2011-03-08 22:00:00.196 Finished recording WIELKIE KONSTRUKCJE: WIEOWIEC W BAHRAJNIE: channel 16710
2011-03-08 22:00:00.439 MainServer::ANN Monitor
2011-03-08 22:00:00.440 adding: htpc as a client (events: 0)
2011-03-08 22:00:00.442 MainServer::ANN Monitor
2011-03-08 22:00:00.444 adding: htpc as a client (events: 1)
2011-03-08 22:00:00.460 TVRec(34): RingBufferChanged()
2011-03-08 22:00:02.284 MainServer::ANN Monitor
2011-03-08 22:00:02.285 adding: htpc as a client (events: 0)
2011-03-08 22:00:02.804 TVRec(34): Changing from WatchingLiveTV to None
2011-03-08 22:00:02.908 TVRec(25): a 34: None
2011-03-08 22:00:03.175 TVRec(25): Changing from None to RecordingOnly
2011-03-08 22:00:03.178 TVRec(25): HW Tuner: 25->25
2011-03-08 22:00:04.817 DVBSM(/dev/dvb/adapter2/frontend0), Warning: Cannot count Uncorrected Blocks
                        eno: Operation not supported (95)
2011-03-08 22:00:04.844 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 14 min
2011-03-08 22:00:04.852 Started recording: "GOO I WESOO": channel 6112 on cardid 25, sourceid 1
2011-03-08 22:00:05.628 Updating status for "GOO I WESOO" on cardid 25 (Tuning => Recording)
2011-03-08 22:00:05.694 EITScanner (25): Started passive scan.

Change History (5)

comment:1 Changed 9 years ago by sphery

Description: modified (diff)

See, also, #9839 (dup) and #9314 (might be related)

comment:2 Changed 9 years ago by Raymond Wagner

Milestone: 0.24.1
Priority: majorminor
Severity: mediumlow

Resetting milestone/priority/severity to defaults.

comment:3 Changed 9 years ago by stuartm

Milestone: unknown

comment:4 Changed 9 years ago by danielk

Note: I could not reproduce in master. Next step.. figure out what commit fixed it there..

comment:5 Changed 9 years ago by danielk

Resolution: Fixed
Status: newclosed

Works in trunk, we're not likely to backport any fix for this to 0.24-fixes at this point.

Note: See TracTickets for help on using tickets.