Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#9774 closed Bug Report - General (Duplicate)

Myth TV Hangs on Exit of Live TV - ATI Prop. Drivers

Reported by: jtkbishop@… Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: low Keywords: myth live tv ati freeze hang
Cc: Ticket locked: no

Description

Hi, been struggling with Myth for a while now. When exiting live TV Myth appears to hang. If I change TTY and then change back again, my menu is visible. It appears that myth can't redraw my menu's for some reason when exiting live TV. This only happens when using opengl as renderer. All other renderer's work fine. I've tried open source and proprietary drivers. Im using onboard ATI HD3200. Thanks !

Attachments (3)

frontend_verbose_playback.log (23.8 KB) - added by jtk 10 years ago.
frontend_verbose_playback.2.log (23.8 KB) - added by jtkbishop@… 10 years ago.
Verbose output of frontend v .24
frontend_verbose_playback.txt (24.1 KB) - added by bbruen@… 10 years ago.
verbose log of frontend playback using ffmpeg and opengl on HD 5450

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by jtk

Changed 10 years ago by jtkbishop@…

Verbose output of frontend v .24

comment:1 Changed 10 years ago by jtkbishop@…

Forgot to mention, I'm using ubuntu 11.04 and myth 0.24

Thanks !

comment:2 Changed 10 years ago by bbruen@…

This is relevant to my interests.

I am running a clean install of ubuntu 11.04 with myth 0.24 on HD 5450 with proprietary fglrx drivers installed.

MythTV hangs on last shown frame when exiting from playback (LiveTV, recorded, or video). Switching to TTY and back is a valid workaround for my problem as well.

Identical settings and hardware using 0.23a worked normally.

Thank you for any help you can offer.

Changed 10 years ago by bbruen@…

verbose log of frontend playback using ffmpeg and opengl on HD 5450

comment:3 Changed 10 years ago by bbruen@…

In creating the log file attached to this ticket, the following line was written to the terminal 26 times.

Application asked to unregister timer 0x0 which is not registered in this thread
. Fix application.

Thank you again.

comment:4 Changed 10 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - Video Playback
Owner: set to markk
Priority: criticalminor
Severity: highlow
Status: newassigned
Version: Unspecified0.24-fixes

Please read the TicketHowTo. Severity and priority are to be left as default.

comment:5 Changed 10 years ago by markk

Resolution: Duplicate
Status: assignedclosed

Duplicate of #9774

comment:6 Changed 10 years ago by markk

That obviously should read duplicte of #9272 :)

comment:7 Changed 9 years ago by alter.alter.ego@…

I may have found a workaround for this. I had the same symptoms after installing Oneiric and using Catalyst Control Centre to configure my displays. Later on, I reconfigured the resolution and refresh rate, but this time using xfce4-display-settings (Setting/Display? on the Applications menu). After that, the problem went away.

Note: See TracTickets for help on using tickets.