Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9798 closed Bug Report - General (Invalid)

mythvideo "Scan for Changes" misses many files

Reported by: rrroonn@… Owned by:
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords: mythvideo, scan, missing files
Cc: Ticket locked: no

Description

I have folders with hundreds of videos. When I "Scan for Changes", mythvideo will find only some of them, and if I scan again, it will find a different set of files. It seems to alternate between scans as to which set is displayed after a scan.

Each scan takes a number of minutes as it processes the same set of files each time. When it was working correctly, subsequent scans would complete quicker unless new files had been added.

Investigation shows that the files are in the videometadata table and seem correct. During the scan, mythvideo seems to think that the filename has changed and updates the table (though no change to the filename has really been made). I was unable to work out a pattern to which filenames are shown and which are not.

It seems to be the logic for how the files are selected for displaying in the list? I have confirmed that no filters are active.

Also, just to confirm, the files have extensions that are known to mythvideo and have not set to ignore. Filenames generally have .mpg, .mkv, .avi etc extensions. It does not seem to be related to the extension type.

The files are actually on a Windows server and the folders have been mounted using the CIFS filesystem. There does not appear to be any differences between ownership and/or permissions that would account for this behavior.

I am using the latest 0.24 autobuild from mythbuntu. I did not see this problem when I was using 0.23.

regards,

Ron

Change History (3)

comment:1 Changed 8 years ago by robertm

Resolution: Invalid
Status: newclosed

Please start on the users list (and post logs there). Your issue is files with identical hashes. This is not a bug.

comment:2 Changed 8 years ago by rrroonn@…

At first I was thinking that you just dont understand and then, as I was posting to the user list, it struck me that you really did. I have the windows version of a symlink of a folder in the video folder tree into another part of the folder structure, so both are being found.

Because of the symlink, Mythvideo will see one instance of a file in a different location and think it has moved, even though there are multiple copies of the same file.

While I now understand the why and how, I'm not sure that this is not a bug. At least I can go away and work around my problem.

thanks Robert,

Ron

comment:3 Changed 8 years ago by robertm

Thanks for the understanding, Ron. Yes, MythVideo? only supports a single copy of each file. Supporting more than one copy of a single file means giving up the ability to reconnect metadata to a record when someone reorganizes or moves files, or moves from local storage to storage groups.

If you have any more questions about the reasoning behind this decision or how it works, I'm available on the lists.

Note: See TracTickets for help on using tickets.