Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9853 closed Bug Report - General (fixed)

mythfilldatabase no longer recognises "--graboptions"

Reported by: tephra@… Owned by: Raymond Wagner
Priority: minor Milestone: 0.25
Component: MythTV - Mythfilldatabase Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi Devs,

I believe a change that Gavin recently submitted to git removed '--graboptions' from mythfilldatabase.

My current crontab entry is:

mythfilldatabase --graboptions '--daily'

This instructs the grab script (tv_grab_au) to only get 1 days worth of information.

Can we please reinstate this, or tell us the correct way to pass commandline instructions to the grabber?

Cheers David

Change History (16)

comment:1 Changed 8 years ago by Raymond Wagner

Status: newinfoneeded_new

Mythfilldatabase still accepts a --graboptions string argument. Are you reporting that option no longer operates as expected, or merely that the --graboptions argument no longer shows up in --help output?

comment:2 Changed 8 years ago by Raymond Wagner

Owner: changed from stuartm to Raymond Wagner

comment:3 Changed 8 years ago by tephra@…

mythtv@crystal:~$ mythfilldatabase --graboptions '--daily' Unhandled option given on command line:

--daily

mythfilldatabase version: master [v0.25pre-2283-g25b716d] www.mythtv.org Valid options are: ...

So it doesn't appear in help, NOR does it operate as expected :)

comment:4 Changed 8 years ago by Raymond Wagner

Status: infoneeded_newnew

comment:5 Changed 8 years ago by Raymond Wagner

Status: newaccepted

comment:6 Changed 8 years ago by dekarl@…

FWIW according to the xmltv example on how to signal the duration to the grabber you want to use "--days 1", if it's called something else, then it's a bug in the grabber... (funny enough the example is with tv_grab_au)

see http://wiki.xmltv.org/index.php/HowtoUseGrabbers#Download_data

comment:7 Changed 8 years ago by tephra@…

ahh - well my tv_grab_au is actually "shepherd" (http://svn.whuffy.com/)

apparently it supports "--days 1"

however it would still be nice to get that --graboptions back :)

comment:8 Changed 8 years ago by Github

Add support for 'passthrough' arguments to the command line parser. Anything given on the command line after a '--' will be accessible as an unprocessed string with GetPassthrough?(). Intended as a work around for instances where a user might want to pass through an argument or value starting with '--'.

Headers are changed, so the binary version gets bumped.

Refs #9853.

Branch: master Changeset: ebbe5e9a0338b8016c7157caa3a3a8e46726609b

comment:9 Changed 8 years ago by tephra@…

Great!

So to confirm?

The old method was: mythfilldatabase --graboptions '--daily'

The new method should be: mythfilldatabase -- --daily

Cheers D.

comment:10 Changed 8 years ago by Raymond Wagner

Not exactly. Support for such behavior was added to the command line parser, to allow that format to be a possible option. Mythfilldatabase itself has not yet been altered to behave in that manner, which is why the commit only referenced this ticket, rather than closing it. We are going to discuss with the XMLTV developers what the proper behavior should be, which may be the above format, or may be leaving the Shepherd grabber to handle things internally.

comment:11 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: acceptedclosed

Move manual grabber settings to anything after a '--', as opposed to the old --graboptions setting. This behavior is not yet documented in --help.

Fixes #9853

Branch: master Changeset: d780af4603f3d1323a32cdc334b1e0d0a0063e76

comment:12 Changed 8 years ago by Max <mythtv@…>

Hello,

Author of Shepherd (tv_grab_au) here. When installed, Shepherd sets up a cron job that calls mythfilldatabase with appropriate options. Now, apparently, we will need to somehow figure out whether the installed version of mythfilldatabase wants to receive '--graboptions' or '--'.

Any tips on how to do that?

Max.

comment:13 Changed 8 years ago by dekarl@…

Max,

fellow grabber author here. What's wrong with just letting the mythtvbackend run tv_grab_au instead of setting up custom cronjobs with custom command line options and direct calls to mythfilldatabase?

You might want tv_grab_au to be run only once (we grab everything everytime anyway mode), so just report back preferredmethod=allatonce to get called once per source instead of potentially once per source per day.

If you get the devs to change the default xmltv timezone to auto you can shorten your setup guide to:

  • add Shepherd/tv_grab_au package of your distribution
  • setup MythTV with xmltvgrabber "Australia (Shepherd)" using the usual way (pointer to general MythTV Setup guide here) and be done.

Regards, Karl

comment:14 Changed 8 years ago by Raymond Wagner

Ticket locked: set
mythbe# mythfilldatabase --version
MythTV Version : v0.25pre-2682-gfb34130

Trac is not a discussion forum. Please direct further discussion to the developer mailing list.

comment:15 Changed 8 years ago by stuartm

Ticket locked: unset

Max, tv_grab_au seems to be operating completely backwards to every other xmltv grabber and I'd like to understand why.

Running MFDB under a cron job with custom arguments should be a fringe case, not the norm and it seems like what you're trying to achieve could/should be done at the grabber using the xmltv API as it was designed. Failing that, additions/extensions to the XMLTV api would be the preferred way forward.

I'm unlocking this ticket so that you can reply although it would be best if replies went instead to the mythtv-development mailing list. I'd like if possible to get this sorted out why I'm bending the ticket rules (which I helped write) in this case.

comment:16 Changed 8 years ago by Max <mythtv@…>

Ok, mailing now.

Note: See TracTickets for help on using tickets.