Opened 8 years ago

Closed 8 years ago

#9886 closed Patch - Bug Fix (fixed)

DVD bookmark dialog crashes frontend

Reported by: Jim Stichnoth <stichnot@…> Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythfrontend crashes after a DVD bookmark dialog selection is made because the required ProgramInfo? object has already been deleted.

MythTV Version : v0.25pre-2529-g63fc3e5
MythTV Branch : master

Attachments (1)

dvdbookmarkfix.patch (458 bytes) - added by Jim Stichnoth <stichnot@…> 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Jim Stichnoth <stichnot@…>

Attachment: dvdbookmarkfix.patch added

comment:1 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

Mythfrontend: Fix a regression/crash in bookmark handling.

The ProgramInfo? object is deleted by the BookmarkDialog?.

Fixes #9886

Branch: master Changeset: 52b393e4d4b420b6f0bc903e67b1ddb046c8660e

Note: See TracTickets for help on using tickets.