Opened 8 years ago

Closed 8 years ago

#9976 closed Bug Report - General (Works for me)

DVB-T: Wrong PMT prevents recording of all channels on UK Mux C

Reported by: freddie@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: 0.24.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I run a Mythbuntu 11.04 system with two DVB-T tuners: a Hauppauge Nova-T and Hauppauge Nova-T 500. Neither are able to record/watch channels on Mux C (Sky News, E4+1 and the such).

The frontend shows: (TLMs) Partial Lock on both tuners for live TV. The backend log shows:

2011-08-10 12:47:05.824 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(22208) desired(22080)
2011-08-10 12:47:05.857 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(23712) desired(22080)
2011-08-10 12:47:05.891 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(22400) desired(22080)
2011-08-10 12:47:05.924 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(24320) desired(22080)
2011-08-10 12:47:05.958 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(24256) desired(22080)
2011-08-10 12:47:05.991 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(23872) desired(22080)
2011-08-10 12:47:06.024 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(22244) desired(22080)
2011-08-10 12:47:06.070 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(24128) desired(22080)
2011-08-10 12:47:06.093 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(22272) desired(22080)
2011-08-10 12:47:06.115 DTVSM(/dev/dvb/adapter101/frontend0) Error: Wrong PMT; pmt->pn(22336) desired(22080)

I have done full rescans (using both cards as the one to do the scanning on). They always find the channels on Mux C. Other DVB-T devices in the house (two televisions on the same aerial have no trouble with these channels).

Change History (5)

comment:1 Changed 8 years ago by Raymond Wagner

Component: MythTV - GeneralMythTV - DVB
Owner: set to Janne Grunau

comment:2 Changed 8 years ago by J.Pilk@…

I suppose this may be a local thing. I get my signal from Waltham and have just made brief recordings from both E4+1 and Sky News.

mythbackend --version

Please attach all output as a file in bug reports. MythTV Version : v0.24.1-55-g8bc2a66 MythTV Branch : fixes/0.24 Network Protocol : 63 Library API : 0.24.20110505-1 QT Version : 4.7.3

comment:3 Changed 8 years ago by freddie@…

Yes, it does appear to be a local thing. Before moving house I was using the Oxford transmitter where the multiplex worked fine. However, after moving to London (I believe the Crystal Palace transmitter) and retuning I can no longer get Mux C.

freddie@bromine:~$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version   : v0.24-243-g9ba3ece
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20101129-1
QT Version       : 4.7.2
Options compiled in:
 linux debug using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg
freddie@bromine:~$ 

comment:4 Changed 8 years ago by J.Pilk@…

Stale database: delete all digital channels and old transports before rescan. If still no good seek help on users' list. Cheers.

comment:5 Changed 8 years ago by Stuart Auchterlonie

Resolution: Works for me
Status: newclosed

I've just done a test recording from Sky News from Crystal Palace and it's recorded fine.

You need to delete all transports and all channels and perform a full rescan.

The delete all transports is vital.....

Stuart

Note: See TracTickets for help on using tickets.