Opened 7 years ago

Closed 6 years ago

#10001 closed Bug Report - General (fixed)

Corrupted bottom bar when playing 1080i HD-PVR content in OSX

Reported by: serversage@… Owned by: Nigel
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: 0.24.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When playing back recordings on my MacMini? (OSX 10.7 Lion) that were captured using an HD-PVR I get an 8 pixel high (based on a screen capture and a count of pixels) bar along the bottom of the screen that looks like corrupted video.

This is very similar to ticket #8409 I believe.

Attachments (3)

CorruptBarExample.jpg (194.6 KB) - added by serversage@… 7 years ago.
Example screenshot
mythtv_playback.log (64.7 KB) - added by serversage@… 7 years ago.
Output of mythfrontend -v playback
osx-quartz-1088.diff (476 bytes) - added by markk 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by serversage@…

Attachment: CorruptBarExample.jpg added

Example screenshot

comment:1 Changed 7 years ago by beirdo

Status: newinfoneeded_new

Sounds like another place that needs a fix 1088->1080. What are you using for playback?

Technically, the HDPVR returns video that's 1920x1088 (to deal with the 16px alignment for the encoder), however, the bottom 8 rows are not at all initialized, so they are to be stripped off and not displayed. We've hit this in several other places as well, and it's possible we need one more tweak somewhere.

comment:2 Changed 7 years ago by markk

Milestone: unknown0.25

comment:3 in reply to:  1 Changed 7 years ago by serversage@…

I apologize for the long delay in replying. Playback is handled by the internal player, and has been tried on OSX 10.6 and OSX 10.7. I have not tried it on the backend which is running Ubuntu 11.04 with an NVidia card simply because my brain wasn't turned on.

To get around the problem I have set the cable box that feeds the HD-PVR to play only in 720p. Like an idiot, I deleted all the 1080i recordings so I no longer have anything on hand to test it with. But, if needed, I can easily get a few recordings if a patch comes along that needs to be run through it's paces.

comment:4 Changed 7 years ago by markk

Status: infoneeded_newnew

But what playback profile are you using for video? OpenGL or Quartz?

Please attach the output of mythfrontend -v playback

It doesn't matter if it is a 720p recording.

Changed 7 years ago by serversage@…

Attachment: mythtv_playback.log added

Output of mythfrontend -v playback

comment:5 Changed 7 years ago by serversage@…

Aah, sorry. Misunderstood. It is using Quartz, and the profile is currently set to CPU+. I dug out an old recording (I actually kept a 1080i), ran myth with -v playback, and then played a few seconds of video. The log is attached.

Changed 7 years ago by markk

Attachment: osx-quartz-1088.diff added

comment:6 Changed 7 years ago by markk

Owner: changed from markk to Nigel
Status: newassigned

I've attached a patch (against master) that *should* fix the problem but I have no way of testing quartz output - so re-assigning to Nigel (though if anyone can confirm it works and doesn't break anything - please ping me).

comment:7 Changed 6 years ago by Github

Resolution: fixed
Status: assignedclosed

Use GetVideoDispDim? rather than GetVideoDim? in OSX

Fixes #10001

This patch has been sitting for 3 months now. Let's put it in, and if there are issues, we'll rework it.

Signed-off-by: Gavin Hurlbut <ghurlbut@…>

Branch: master Changeset: 2175b3a00512a3db93e3e62bddd34bc1c62b6ed0

Note: See TracTickets for help on using tickets.