Opened 8 years ago

Closed 8 years ago

#10091 closed Bug Report - General (Fixed)

LiveTV: OSD episode field not always cleared in browse mode

Reported by: warpme@… Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - Video/OSD Rendering Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

HI, I'm on v0.25pre-3435-g51c8ce1. Entering LiveTV browse mode shows properly all info on OSD for programs having EPG with non-empty episode field. Browsing into program which has empty-episode field has OSD showing episode from last program which has episode field non-empty. In other words, OSD episode filed isn't cleared for programs having this field empty. Reproduce: 1\start LiveTV; 2\browse across EPG; 3\select program with non-empty episode field; 4\go to program with empty episode. Result: OSD shows episode from previous program.

Change History (4)

comment:1 Changed 8 years ago by robertm

Status: newinfoneeded_new

Do you mean *episode*, or subtitle? Episode is a number, and is only available in current master, and never used for LiveTV. Subtitle is something which has been present for many years.

comment:2 Changed 8 years ago by warpme@…

Indeed I wasn't sure about terminology. I used term "episode" as OSD field in question is equal to data shown in colon called "Episode" on myth web per channel listings. From context point of view, IMHO term subtitle is much more reasonable term. In respect of Your question I'm almost sure issue is about subtitle.

comment:3 Changed 8 years ago by warpme@…

I just upgraded to 47d52964f9 and it looks like problem was solved by some commits between 47d52964f9 & 51c8ce1. From my perspective ticket might be closed with status resolved. Thx

comment:4 Changed 8 years ago by robertm

Resolution: Fixed
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.