Opened 8 years ago

Closed 8 years ago

#10159 closed Bug Report - General (Works for me)

No video during LiveTV after displaying EPG

Reported by: Daniel Nilsson <daniel@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using MythTV version v0.24.1-101-g5da2367 I have issues switching to the EPG during LiveTV. The EPG will display, sometimes with the LiveTV window actually still playing the LiveTV feed and sometimes only with audio and a blank window where the LiveTV video should have been displayed inside the EPG. The most important issue though is that when exiting the EPG I never get the LiveTV video back, only the audio. Instead of the video only the theme background is displayed.

I have attached a log file at the "most" verbosity level. During this session I start LiveTV, enter the EPG, exit the EPG and finally exit LiveTV.

Please let me know what more information is required.

Attachments (2)

mythfrontend.version (731 bytes) - added by Daniel Nilsson <daniel@…> 8 years ago.
Version information
livetv_epg_enter_exit.log.gz (47.5 KB) - added by Daniel Nilsson <daniel@…> 8 years ago.
Live TV, EPG enter-exit log file

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Daniel Nilsson <daniel@…>

Attachment: mythfrontend.version added

Version information

Changed 8 years ago by Daniel Nilsson <daniel@…>

Live TV, EPG enter-exit log file

comment:1 Changed 8 years ago by Frank Phillips <frankalso@…>

I have tried patching v0.24.1-121-gb151996 with commit 72976f3 from master:

libmythui: Stop the main window background from automatically painting.

Instead of seeing the background upon exiting EPG in LiveTV, with this patch it is just black, so it doesn't help. With or without the patch, my workaround is to pause/unpause and the video can be seen again. Occasionally the video will come back from EPG without being blocked.

comment:2 in reply to:  1 ; Changed 8 years ago by daniel@…

Replying to Frank Phillips <frankalso@…>:

I have tried patching v0.24.1-121-gb151996 with commit 72976f3 from master:

libmythui: Stop the main window background from automatically painting.

Instead of seeing the background upon exiting EPG in LiveTV, with this patch it is just black, so it doesn't help. With or without the patch, my workaround is to pause/unpause and the video can be seen again. Occasionally the video will come back from EPG without being blocked.

Could you give some details on the front end configuration? Since I run the mythfrontend using mythbuntu diskless I have the chance to boot the exact same OS/MythTV image on different hardwares. This issue seems to be a lot easier to reproduce on my main frontend which is using an Nvidia graphics card (GeForce? FX 5200 using nvidia driver 173.14.22-0ubuntu11). Not sure if this makes a difference or not, but the graphics card is one difference between the hardwares I'm attempted to use with mythfrontend.

comment:3 in reply to:  2 ; Changed 8 years ago by Frank Phillips <frankalso@…>

I have three frontends: Ion, 8400GS, and Intel. The laptop with Intel graphics does not have this problem. I tried both OpenGL and Qt painters, and Mythbuntu and MythCenter? themes on all three with no difference. The nvidia drivers I use are 290.x or newer.

When changing profiles from VDPAU to CPU++/Normal/Slim? the problem is not seen. What profile decoder/renderer do you use with the FX5200?

Another thing that clears the video is a quick EPG enter/exit.

comment:4 in reply to:  3 Changed 8 years ago by daniel@…

Replying to Frank Phillips <frankalso@…>:

I have three frontends: Ion, 8400GS, and Intel. The laptop with Intel graphics does not have this problem. I tried both OpenGL and Qt painters, and Mythbuntu and MythCenter? themes on all three with no difference. The nvidia drivers I use are 290.x or newer.

When changing profiles from VDPAU to CPU++/Normal/Slim? the problem is not seen. What profile decoder/renderer do you use with the FX5200?

Another thing that clears the video is a quick EPG enter/exit.

Hi, I use the the standard decoder (ffmpeg it seems) with video renderer xv-blit and OSD renderer softblend. This profile is CPU+ on my install.

Performing a pause/resume after exiting the EPG restores the video in my case as well.

I guess it would be difficult to point to Nvidia drivers since the configurations are pretty different but the symptoms are the same.

comment:5 Changed 8 years ago by danielk

Resolution: Works for me
Status: newclosed

Tested in master, works for me there. If this is a 0.24 only problem we won't fix there.

Note: See TracTickets for help on using tickets.