Opened 7 years ago

Closed 7 years ago

#10210 closed Bug Report - General (fixed)

bad ratio in LiveTV

Reported by: FabriceMG <mgf@…> Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since updating the mythbuntu ppa December 9, 2011, when I go into the live TV, the ratio of the image is 4 / 3 while the TV channel is 16 / 9 and it does not change. If I change TV channel, this time the ratio is good (16 / 9). For recordings, the ratio is good. I have not changed between the ppa update of 08 December 2011 (everything worked fine) and that of December 9, 2011. I correct the problem by changing the TV channel, then back, or I change the ratio manually with the menu.

Attachments (1)

aspectPatch.diff (419 bytes) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by markk

Priority: majorminor
Status: newaccepted

It's a known issue introduced in 2c930a727e4d0f92

Changed 7 years ago by anonymous

Attachment: aspectPatch.diff added

comment:2 Changed 7 years ago by mythtv@…

I believe this issue is caused by InitVideo? being called when the dummy video file is loaded, then the actual LiveTV file being loaded and video not being reinitialized to the new aspect ratio - calling ReinitVideo? fixes the problem.

However, while the patch does fix the issue, I can't quite work out why this is only an issue when first starting LiveTV and not switching channel, so I can;t be sure that this is actually fixing the root cause of the problem.

comment:3 Changed 7 years ago by Github

Resolution: fixed
Status: acceptedclosed

Fix initial live TV video aspect ratio.

Instead of setting the aspect ratio for mythtranscode, just have mythtranscode go direct to the decoder without interfering with normal playback behaviour.

Closes #10210

Branch: master Changeset: 56aea3054a0d1fdd772bf48d9a19ae549787f8a0

Note: See TracTickets for help on using tickets.