Opened 8 years ago

Closed 8 years ago

#10283 closed Patch - Bug Fix (fixed)

CEA-708 caption font is sometimes excessively large

Reported by: Clayton Smith <argilo@…> Owned by: danielk
Priority: minor Milestone: 0.25
Component: MythTV - ATSC Version: Master Head
Severity: medium Keywords: cea-708
Cc: Ticket locked: no

Description

When watching an ATSC recording, if closed captions are turned on (via the "T" key, for example) before any CEA-708 captions have occurred in the stream, then captions will be displayed with an excessively large font size, such that the letters overlap and extend off the screen. A good way to reproduce this is to press "T" while the "Playback starting..." screen is displayed, before the recording begins playing.

This occurs because the DisplayCC608Subtitles function in subtitlescreen.cpp is called before the DisplayCC708Subtitles function is called. DisplayCC608Subtitles updates m_safeArea, and then DisplayCC708Subtitles doesn't realize this has happened and so doesn't bother to update m_708fontSizes. This patch modifies DisplayCC708Subtitles such that it always sets m_708fontSizes on its first invocation.

I have tested it with the PBS test material ( http://ncamftp.wgbh.org/DTV/CEA%20test%20material/) and recorded programs from various local ATSC stations. As far as I can tell, the problem is fixed and no new problems have appeared.

Attachments (1)

large-fonts.patch (1.1 KB) - added by Clayton Smith <argilo@…> 8 years ago.
patch to fix large caption font bug

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Clayton Smith <argilo@…>

Attachment: large-fonts.patch added

patch to fix large caption font bug

comment:1 Changed 8 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

Fixes #10194. Fixes #10283. Refactor of 708 caption handling.

Note there are a couple minor issues. The default OSDSubFont is not as readable as the old 708 default font and the font can not be reset without restarting mythfrontend. These issues aren't really caused by this changeset though, so I'm applying this as is and leaving those issues to be fixed in a subsequent patch.

Branch: master Changeset: 8038cb11da4e4f803e88f4476d9e49348bb3ca19

Note: See TracTickets for help on using tickets.