Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

#10359 closed Bug Report - General (Fixed)

Changing languages (mythfrontend --prompt) results in a segfault

Reported by: jpoet Owned by: stuartm
Priority: critical Milestone: 0.25
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Run "mythfrontend --prompt" to change languages. At the end of the process, mythfrontend segfaults.

BT attached.

Attachments (1)

mythfrontend-prompt.gdb (25.4 KB) - added by jpoet 2 years ago.
Back Trace

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by jpoet

Back Trace

comment:1 Changed 2 years ago by stuartm

  • Milestone changed from unknown to 0.25
  • Status changed from new to accepted

comment:2 Changed 2 years ago by stuartm

  • Priority changed from minor to critical

comment:3 Changed 2 years ago by stuartm

Looks like other very bad things happen here. Seems to be a regression in the bootstrap/startup code, probably the order of events was changed without proper testing. I'll try to get this figured out/fixed before the release.

comment:4 Changed 2 years ago by stuartm

  • Resolution set to Fixed
  • Status changed from accepted to closed
  • Version changed from Unspecified to Master Head

Fixed in [c7a1e812dce42615fd01686dcb172e964bace606] thanks to Daniel.

Also ref [81e72c848] which fixes some other issues when loading the frontend after closing the language/database prompt

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.