Opened 9 years ago

Closed 8 years ago

#10419 closed Bug Report - General (Invalid)

Multirec recording failing in certain conditions

Reported by: pjokinen@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

One of simultaneously starting multirec recordings from single card (SAA7134) fails every time when in the same multiplex and at the same time:
Two or more recordings are started AND one or more recordings ends AND there isn't any other ongoing recordings.

This is only condition when I have seen recordings failing.

Attachment is snippet of mythbackend log with -v most. Two recordings end at 19:00:00 (Emmerdale (S) and Nelosen sää) and two recordings start at 19:00:00 in same multiplex (Seitsemän Uutiset and Pulkkinen). Seitsemän uutiset records succesfully but Pulkkinen fails.

Attachments (1)

mythbackend.log (104.1 KB) - added by pjokinen@… 9 years ago.
mythbackend log about failing multirec recording

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by pjokinen@…

Attachment: mythbackend.log added

mythbackend log about failing multirec recording

comment:1 Changed 8 years ago by danielk

Status: newinfoneeded_new

Can you reproduce this in master? In master, the only thing I can see causing this is if the StreamHandler? is not running when we run DVBSignalMonitor::UpdateValues?(), and I can't see any way for that to happen without an error message of some kind.

comment:2 Changed 8 years ago by pjokinen@…

Thank you for looking into this. This issue is fixed in master, I have been running and testing it for few days and have been unable to reproduce.

comment:3 Changed 8 years ago by danielk

Resolution: Invalid
Status: infoneeded_newclosed

Marking as invalid since it appears to have been resolved (no judgement on the quality of the original report, we simply don't know what fixed this).

Note: See TracTickets for help on using tickets.