Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

#10448 closed Patch - Translation (fixed)

Updated Polish translations for all modules

Reported by: warpme@… Owned by: knight
Priority: minor Milestone: 0.25
Component: Translations Version: Master Head
Severity: medium Keywords: Polish translations
Cc: Ticket locked: no

Description

Pls find updated PL translations for all Myth modules. All plugins seems to be now 100% translated. Mythfronted is also almost fully translated - except setup screens and some deep screens in theme. I'll finish this when new MythUI setup will be implemented. BTW: There are warnings reported by QT Linguist - but for me it looks like Linguist bug.
Enjoy

Attachments (2)

mythtv-master-20120313-g1399a9c-mythfrontend-pl_translations.tar.bz2 (217.2 KB) - added by warpme@… 2 years ago.
mythtv-master-20120313-g1399a9c-plugins-pl_translations.tar.bz2 (91.8 KB) - added by warpme@… 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by warpme@…

Changed 2 years ago by warpme@…

comment:1 Changed 2 years ago by warpme@…

Hi,
Is there reason why this patch is not applied ?

comment:2 Changed 2 years ago by knight

  • Milestone changed from unknown to 0.25
  • Owner changed from kenni to knight
  • Status changed from new to assigned

I'm sorry Warpme... It looks like I didn't receive the email notification...

(I usually try to commit them the same day they are received unless there is a problem...)

comment:3 Changed 2 years ago by warpme@…

Absolutely not a problem.
I know busy ppl have tons of mails :-)
Thx for Your quick response !
-br

comment:4 in reply to: ↑ description Changed 2 years ago by knight

  • Status changed from assigned to infoneeded

Hi Warpme!

Replying to warpme@…:

BTW: There are warnings reported by QT Linguist - but for me it looks like Linguist bug.

Actually Qt Linguist is quite right on quite a few of them... I have taken, randomly, a few examples...

e.g. in MythFrontend

"Result of this filter : %n video(s)"

was translated as

Singular: "Wynik filtrowania: %1 flmów"

For this Qt Linguist reports:

"Translation does not refer to the same place marker as in the source text."
"Translation does not contain the necessary %n place marker."

which is right..

  • You get

"Translation does not refer to the same place marker as in the source text."

because you replaced in the original text the %n marker (which represents the number of videos in this case) with %1 which, for this sentence, means nothing so this translation will not give the expected result.

(%n is used to deal with plurals, %1 (%2, etc...) are used to fill in value passed by the program in a string.)

  • You get

"Translation does not contain the necessary %n place marker."

because you only filled in the singular translation, not the pauscal and plural ones which absolutely need to be filled in if you want the translation of that sentence to work correctly...

Qt Linguist is complaining because it doesn't find the %n place marker in the pauscal and plural translation (because they are empty) which is why it complains.

You also get warnings for differences in punctuations like these:

"Choose a satellite position."

was translated into

"Wybież pozycję satelitarną"

which has no "." (period) at the end like the original sentence.

Unless you have a good reason to remove it it's usually preferable to keep the original text punctuation (with, of course, the necessary adjustments for your language).

Qt Linguist can give you some harmless messages when you add periods to indicate a word has been abbreviated and it was not present in the original text or when the original text had a "&" (ampersand) in it because they are given a special meaning under some circumstances (which don't apply to MythTV) but the rest should not be easily discarded.

Warpme, could you please check two things for me:

  • Did you send me the right files? You mention that MythFrontend should be almost fully translated while the MythFrontend file I received is around 60% translated (2720 translated/4667 total)?
  • Which version of Qt Linguist are you using? I'm beginning to think you don't see the pauscal and plural translation fields because none of them are filled in and I have a feeling that's because your Qt Linguist might not show them to you...

(Somebody else had a similar problem recently because he was using an old Qt3 Qt Linguist (his PC had both Qt3 and Qt4 and unfortunately the wrong one was used).)

The first problem (a lower number of translation than expected) could possibly be caused by an old Qt Linguist too...

Please let me know if you want me to commit these as is or want to resubmit new patches...
If you need any help you can ping me on IRC (knightr) or by email (IRC is usually safer though... (-; ).

By the way, please never submit QMs, these take up unnecessary space on Trac and I always regenerate them anyway (and quite possibly not with the same arguments than the ones you used).

Have a nice day!

Nicolas

PS: By the way, thank you for the note on ticket #10433.

comment:5 Changed 2 years ago by Github

  • Resolution set to fixed
  • Status changed from infoneeded to closed

Update Polish MythFrontend and all plugins translation
from Warpme.

Thank you Warpme!

Closes #10448

Branch: master
Changeset: 585ec0c25d59de258fa7596aa0e81a40bf047368

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.