Opened 7 years ago

Closed 7 years ago

#10462 closed Bug Report - Crash (Invalid)

"Error opening jump programme file" when opening Live TV on 0.25

Reported by: Joe Nyland <joenyland@…> Owned by:
Priority: major Milestone:
Component: MythTV - General Version: Master Head
Severity: medium Keywords: jump file error crash
Cc: Ticket locked: no

Description

When selecting Live TV from the main MythTV menu, the screen appears to stall, then I am shown a message saying "Error opening jump programme file". This message is displayed 9/10 times. OTher times, I am given the message: "Video frame buffering failed too many times". I have not watched Live TV successfully since upgrading to 0.25 from 0.24.

After receiving this error, the frontend will crash - Mac OS crash report will be attached, along with trace and log file for the frontend.

Please advise what kind of log is required (if any) for the backend, as I'm not seeing any problems being logged in the normal 'default' log.

Attachments (4)

gdb.txt (63.7 KB) - added by Joe Nyland <joenyland@…> 7 years ago.
Backtrace
mythfrontend.20120315201739.55632.log (120.7 KB) - added by Joe Nyland <joenyland@…> 7 years ago.
MythFrontend log
mythfrontend.mac.crash.report.2.txt (62.6 KB) - added by Joe Nyland <joenyland@…> 7 years ago.
Mac OS X Crash report
mythbackend.log.zip (28.9 KB) - added by Joe Nyland <joenyland@…> 7 years ago.
MythBackend? log

Download all attachments as: .zip

Change History (17)

Changed 7 years ago by Joe Nyland <joenyland@…>

Attachment: gdb.txt added

Backtrace

Changed 7 years ago by Joe Nyland <joenyland@…>

Changed 7 years ago by Joe Nyland <joenyland@…>

Mac OS X Crash report

comment:1 Changed 7 years ago by Joe Nyland <joenyland@…>

Sorry, forgot to add that my backend is: MythTV Version : v0.25-beta-107-gc09b076 MythTV Branch : master Network Protocol : 72 Library API : 0.25.20120307-2 QT Version : 4.6.2 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_v4l1 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

And my frontend: MythTV Version : v0.25-beta-144-g3e26728 MythTV Branch : master Network Protocol : 72 Library API : 0.25.20120314-3 QT Version : 4.8.0 Options compiled in:

debug use_hidesyms darwin_da using_corevideo using_backend using_bindings_php using_darwin using_firewire using_frontend using_hdhomerun using_ceton using_iptv using_libcrypto using_libdns_sd using_libxml2 using_libudf using_mheg using_opengl_video using_qtwebkit using_qtscript using_appleremote using_bindings_php using_darwin_da using_mythtranscode using_opengl using_ffmpeg_threads using_live using_mheg using_libxml2 using_libudf

Thanks,

Joe

comment:2 Changed 7 years ago by JYA

And what does the backend states?

The error you are seeing is usually a problem with your backend and your DVB card.

So you would need to provide backend logs

comment:3 Changed 7 years ago by sphery

Do you have the setting:

Show the program guide when starting Live TV
This starts the program guide immediately upon starting to watch Live TV.

enabled? If so, does disabling that setting make Live TV startup stable? If so, this is a duplicate of #9845 .

comment:4 in reply to:  2 Changed 7 years ago by Joe Nyland <joenyland@…>

Replying to jyavenard:

And what does the backend states?

The error you are seeing is usually a problem with your backend and your DVB card.

So you would need to provide backend logs

Please find my full backend log attached now.

Changed 7 years ago by Joe Nyland <joenyland@…>

Attachment: mythbackend.log.zip added

comment:5 in reply to:  3 Changed 7 years ago by Joe Nyland <joenyland@…>

Replying to mdean:

Do you have the setting:

Show the program guide when starting Live TV
This starts the program guide immediately upon starting to watch Live TV.

enabled? If so, does disabling that setting make Live TV startup stable? If so, this is a duplicate of #9845 .

Yes, this was enabled.

I have disabled this setting, but I still get the error "Error opening jump programme file" when trying to view live TV, I'm afraid.

Thanks,

Joe

comment:6 Changed 7 years ago by JYA

Have you ever got liveTV working on any other systems?

I see that you have defined a Storage Group for livetv, but that folder actually exists? and the backend have the right permissions to write to it ?

comment:7 in reply to:  6 Changed 7 years ago by Joe Nyland <joenyland@…>

Replying to jyavenard:

Have you ever got liveTV working on any other systems?

Not since upgrading to 0.25-beta.

I see that you have defined a Storage Group for livetv, but that folder actually exists? and the backend have the right permissions to write to it ?

Yes, both /var/lib/mythtv/livetv and /mnt/mythtv/livetv are writable by MythTV. Furthermore, an .mpg file is created in the live TV folder on my array by MythTV, but is only around 5MB:

joe@MythTVServer1:~$ ls -lth /mnt/mythtv/livetv/
total 5.0G
-rw-r--r-- 1 mythtv mythtv    0 2012-03-16 06:57 1001_20120316065924.mpg
-rw-r--r-- 1 mythtv mythtv 4.8M 2012-03-16 06:57 1001_20120316065913.mpg
-rw-r--r-- 1 mythtv mythtv    0 2012-03-16 06:57 1001_20120316065912.mpg

This is from an attempt to view live TV, just now.

comment:8 Changed 7 years ago by Joe Nyland <joenyland@…>

Just upgraded to the latest MythBuntu? 0.25-beta build of MythTV-Backend, but I'm still getting the same error message, I'm afraid.

joe@MythTVServer1:~$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version : v0.25-beta-165-g53761e2
MythTV Branch : master
Network Protocol : 72
Library API : 0.25.20120315-2
QT Version : 4.6.2
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_v4l1 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

Thanks,

Joe

comment:9 Changed 7 years ago by Joe Nyland <joenyland@…>

Possibly related to this bug: 9034?

It leads on to another bug: 10178 but this doesn't seem to be going anywhere at the moment.

I could probably get a tcpdump log, like the other reporter has, at some point today, but is it required?

Thanks,

Joe

comment:10 Changed 7 years ago by JYA

the issue is obviously on your backend side (especially as it impacts all your frontends). So I doubt a tcpdump will help in any ways.

comment:11 Changed 7 years ago by Joe Nyland <joenyland@…>

Agreed.

Any suggestions how I can obtain more info on why it's not giving me live TV?

As I mentioned earlier, a live TV recording file is created, but then the frontend reports this error. If I then go back in to Watch Recordings, select the Live TV view, I am able to watch the short live TV recording it created, so the backend it tuning ok...

comment:12 Changed 7 years ago by Joe Nyland <joenyland@…>

This seems to have been caused by an NFS issue when writing the live TV buffer to / reading the recording back from my file server. I had discounted the file storage as being a problem, as I mentioned before the file was being created,just not read back.

A restart of my file server and remounted the NFS shares, live TV is back in action.

However, I'm seeing 0 byte recording files for live TV when I start watching live TV, and when changing channels. I'll take this up with the mythtv-users list though, as it's nothing to do with this issue, I don't think.

Thanks for you help.

Joe

comment:13 Changed 7 years ago by danielk

Resolution: Invalid
Status: newclosed

Thanks for reporting back. There is a ticket on the 0-byte files #10443. In short they are supposed to be created, but they are also supposed to be deleted quickly and they aren't being deleted quickly right now. When using NFS you want to set the actimeo low (1 works best in my experience, though some may need 0).

Note: See TracTickets for help on using tickets.