Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 21 months ago

Last modified 21 months ago

#10489 closed Bug Report - General (Fixed)

recording doesn't record when watching live tv on same tuner

Reported by: Ronald Frazier <ron@…> Owned by: danielk
Priority: major Milestone: 0.26
Component: MythTV - Recording Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Since upgrading to master I've had several recordings fail to record. Today I was able to verify the cause. When you are watching live tv on a tuner and a scheduled recording is about to start on that tuner, the box pops up asking whether you want to cancel the recording, watch it while it records, or go back to the menu and let it record. If you choose to watch it while it records, the channel changes as expected and the new program begins playing. However, if you then exit out of livetv to the main menu, the recording stops. If you go into the watch recordings screen, the program only appears in the livetv group, and only contains the segment that you were watching live. However, there is also a second copy of the recording that is a zero byte file that myth thinks is recording.

If you look at the recording history screen while the program is supposed to be recording, it reports the the program is recording. However, if you look at the tuner status, you can see that the tuner is not recording.

So it would appear to me that the extra zero byte recording is throwing off the recording process and it's not following the sequence properly the way live tv does.

Attachments (0)

Change History (15)

comment:1 Changed 22 months ago by danielk

  • Milestone changed from unknown to 0.26
  • Priority changed from minor to major
  • Status changed from new to accepted

comment:2 Changed 21 months ago by danielk

It looks like the pseudoLiveTVRecording pointer is getting cleared so the next_state is in TVRec::StopLiveTV() is getting set to None rather than RecordingOnly?.

comment:3 Changed 21 months ago by danielk

pseudoLiveTVRecording is set around line 606 and is still set when StopLiveTV() is first called, but gets reset to null in the "CheckForRecGroupChange?()". This indicates that the recording group somehow gets reset during the recording to "LiveTV" even though pseudoLiveTVRecording is set.

comment:4 Changed 21 months ago by anonymousdog@…

Daniel,

This ticket is only partially a duplicate of #10726: the symptoms noted in comments are different. It appears that the patch (lomion posted in #10726) actually fixes the issues noted here and there, but not the "watch and record" menu function which is still broken per lomion's report in #10726 (comment #4?).

#10726 includes comments about the 'I need a tuner' menu 'watch and record' option not working:

  • This ticket is 'scheduled pseudo-LiveTV recordings record as LiveTV and a zero byte file'.
  • #10726 includes the suggestion that the 'watch and record' menu option has no effect on LiveTV session, and scheduled recording never happens with pre-existing LiveTV session continuing. These additional symptoms were reported within the comments of that ticket although the OP really DID duplicate this ticket.

Would you prefer a bug posted about the ineffective "watch and record" menu option?

comment:5 Changed 21 months ago by lomion@…

The strange thing to me is, that the code I changed in the patch for #10726 was the same in 0.24 where all this behaviour worked. I have no idea how it worked back in 0.24 because frankly the original code should have never worked :-| ...

Anyway, what is IMHO missing to make this patch work for "watch and record" is to set the RecordingGroup? to "Default" when "watch and record" is selected. I could not find the right place to do that but it should be similar as for pressing the "Record" button (calling SetLiveRecording? in the encoder i believe). I lack the big picture for that code to do the fix right ... I hope for Daniel to have it :-)

comment:6 Changed 21 months ago by Daniel Thor Kristjansson <danielk@…>

In 40b0770272a601ce335a9fc7227221ea3c11cd5b/mythtv:

Refs #10489. Bypass IsTunable? check for kPseudoChangeChannel.

When a scheduled recorder grabs a LiveTV instance we already know
the channel is tunable on this recorder.

comment:7 Changed 21 months ago by Daniel Thor Kristjansson <danielk@…>

In 1675dd2a7eaa53f15b769e76f0d0f8bd7d80b99a/mythtv:

Refs #10489. Use regular recording group when grabbing LiveTV recorder.

comment:8 Changed 21 months ago by Daniel Thor Kristjansson <danielk@…>

In 2154b3bf91b9a2e319e49860caff4d97bd80dc7b/mythtv:

Refs #10489. Bypass IsTunable? check for kPseudoChangeChannel.

When a scheduled recorder grabs a LiveTV instance we already know
the channel is tunable on this recorder.

comment:9 Changed 21 months ago by Daniel Thor Kristjansson <danielk@…>

In 21306c3929b66249654eab1054a3e5884d225a5e/mythtv:

Refs #10489. Use regular recording group when grabbing LiveTV recorder.

comment:10 Changed 21 months ago by danielk

Please test with the latest master. You may also be able to backport these changes to 0.25/fixes, but there is no guarantee that will work.

comment:11 Changed 21 months ago by Steven Adeff <adeffs.mythtv@…>

For 0.25-fixes I had to make some slight changes to the line locations in the patches, but they passed the patch dry-run. I'm compiling now and will try to test them out and tell the housemates to test it as well when they're watching.

are there any specific scenarios we should look at to verify correct operation?

thanks!

comment:12 Changed 21 months ago by danielk

  • Resolution set to Fixed
  • Status changed from accepted to closed

I believe this is fixed in master by [21306c39].

comment:13 Changed 21 months ago by anonymousdog@…

Was this committed to 0.25? If so, it doesn't seem to be working with mythbuntu repos latest, 0.25.2+fixes.20120801.46cab93-0ubuntu0mythbuntu4.

comment:14 Changed 21 months ago by lomion@…

No, it was not committed! It was committed to master and some development branches. I'm still using a patched, self-compiled mythtv on mythbuntu to get this fix into my 0.25 setup ...

The 0.26 is supposed to be released soon and I guess they are trying to force us to switch to the beta version by not committing these vital changes to 0.25-fixes :-|

comment:15 Changed 21 months ago by stuartm

  • Ticket locked set

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.