Opened 8 years ago

Closed 7 years ago

#10726 closed Bug Report - General (Duplicate)

Start recording and keep watching LiveTV broken

Reported by: lomion@… Owned by: danielk
Priority: minor Milestone: 0.25.1
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

When a scheduled recording is about to start while I am using the only recorder (set to 2 virtual recorders) for tivetv, I get the pop-up to decide what to do. Whe selecting "record and keep watching" it switches channel, starts playback but does not record it permanently. When I exit livetv the mythtv assumes it is still recording but it is not and the recorder is free. This behaviour worked in 0.24!

Attachments (1)

10726.patch (995 bytes) - added by lomion@… 7 years ago.
This patch helps with recording a LiveTV show but the pop-up is still not working as intended

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by Steven Adeff <adeffs.mythtv@…>

I'm noticing this too.

to expand on what is happening.

when a scheduled recording starts while the tuner is being used for livetv, that recording is placed in the LiveTV group and not the group the recording schedule specifies, be it default or another.

This causes the recording to not show in the Watch Recordings screen, and to expire.

In the logs it also looks like, in this case, when the user exits live tv the recording does indeed stop.

below is the log output from a recording that initiated during a LiveTV session on tuner 5:

Jun  3 18:37:35 MythCenter mythbackend[17345]: I ProcessRequest
tv_rec.cpp:2763 (StopLiveTV) TVRec(5): StopLiveTV(void) curRec:
0x7e305e28 pseudoRec: 0xffffffff8ffb3c58
Jun  3 18:37:35 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:1014 (HandleStateChange) TVRec(5): Changing from
WatchingLiveTV to None
Jun  3 18:37:35 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:4158 (ClearFlags) TVRec(5):
ClearFlags(FrontendReady,CancelNextRecording,) ->
RunMainLoop,RecorderRunning,RingBufferReady,
Jun  3 18:37:35 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:3370 (HandleTuning) TVRec(5): HandleTuning Request:
Program(NULL) channel() input() flags(KillRec,KillRingBuffer,)
Jun  3 18:37:35 MythCenter mythbackend[17345]: I TVRecEvent
mpegrecorder.cpp:1332 (StopEncoding) MPEGRec(/dev/hdpvr1):
StopEncoding
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
mpegrecorder.cpp:1348 (StopEncoding) MPEGRec(/dev/hdpvr1): Encoding
stopped
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
DeviceReadBuffer.cpp:171(Stop) DevRdB(/dev/hdpvr1): Stop() -- begin
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
DeviceReadBuffer.cpp:180(Stop) DevRdB(/dev/hdpvr1): Stop() -- end
Jun  3 18:37:37 MythCenter mythbackend[17345]: I RecThread
mpegrecorder.cpp:1113 (run) MPEGRec(/dev/hdpvr1): run finishing up
Jun  3 18:37:37 MythCenter mythbackend[17345]: I RecThread
mpegrecorder.cpp:1332 (StopEncoding) MPEGRec(/dev/hdpvr1):
StopEncoding
Jun  3 18:37:37 MythCenter mythbackend[17345]: I RecThread
mythdbcon.cpp:395 (PurgeIdleConnections) New DB connection, total: 18
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:4158 (ClearFlags) TVRec(5): ClearFlags(RecorderRunning,) ->
RunMainLoop,RingBufferReady,
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
mpegrecorder.cpp:1332 (StopEncoding) MPEGRec(/dev/hdpvr1):
StopEncoding
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
recorderbase.cpp:89 (SetRecording) RecBase(5:/dev/hdpvr1):
SetRecording(0x0)
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:812 (FinishedRecording) TVRec(5):
FinishedRecording(1478_2012-06-03T17:00:01) damaged
recq:<RecordingQuality overall_score="0"
key="1478_2012-06-03T17:00:01" countinuity_error_count="0"
packet_count="39117301">#012    <Gap start="2012-06-03T18:37:31"
end="2012-06-03T19:00:00" duration="1349"/>#012</RecordingQuality>
Jun  3 18:37:37 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:862 (FinishedRecording) TVRec(5):
FinishedRecording(1478_2012-06-03T17:00:01)#012#011#011#011title: 12
Angry Men#012#011#011#011in recgroup: LiveTV status: Recorder
Failed:Recorder Failed not_dummy finished_now
Jun  3 18:37:38 MythCenter mythbackend[17345]: I TVRecEvent
livetvchain.cpp:130 (FinishedRecording) Chain: Updated endtime for
'1478_20120603170001' to 20120603183737
Jun  3 18:37:38 MythCenter mythbackend[17345]: I TVRecEvent
programinfo.cpp:3806 (SaveVideoProperties) SaveVideoProperties(0x38,
0x30)
Jun  3 18:37:38 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:4158 (ClearFlags) TVRec(5): ClearFlags(RecorderRunning,) ->
RunMainLoop,RingBufferReady,
Jun  3 18:37:38 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:3548 (TuningShutdowns) TVRec(5): Tearing down RingBuffer
Jun  3 18:37:38 MythCenter mythbackend[17345]: I TVRecEvent
tv_rec.cpp:4158 (ClearFlags) TVRec(5): ClearFlags(PENDINGACTIONS,) ->
RunMainLoop,RingBufferReady,
Jun  3 18:37:38 MythCenter mythbackend[17345]: I ProcessRequest
tv_rec.cpp:4149 (SetFlags) TVRec(5): SetFlags(FrontendReady,) ->
FrontendReady,RunMainLoop,RingBufferReady,

so, even though the recording is scheduled, when the user leaves LiveTV it still stops the recording!

Last edited 7 years ago by Raymond Wagner (previous) (diff)

comment:2 Changed 7 years ago by danielk

Owner: set to danielk
Status: newaccepted

comment:3 Changed 7 years ago by Steven Adeff <adeffs.mythtv@…>

If one changes the channel the recording also stops.

it looks as if this part of how live tv is handled is now broken.

comment:4 Changed 7 years ago by Steven Adeff <adeffs.mythtv@…>

When this occurs, if you press the "record" button on the remote, myth says "recording cancelled", if you press it again, it again says, "recording canceled".

Changed 7 years ago by lomion@…

Attachment: 10726.patch added

This patch helps with recording a LiveTV show but the pop-up is still not working as intended

comment:5 Changed 7 years ago by anonymousdog@…

Please consider raising the priority on this ticket. This bug makes LiveTV unsafe to use (as it risks missing scheduled recordings).

comment:6 Changed 7 years ago by beirdo

Ticket locked: set

comment:7 Changed 7 years ago by danielk

Resolution: Duplicate
Status: acceptedclosed

This appears to be a duplicate of #10489.

Note: See TracTickets for help on using tickets.