Opened 8 years ago

Closed 8 years ago

#10518 closed Bug Report - General (Fixed)

mythbackend stopped responding and stopped recording

Reported by: Steven Adeff <adeffs.mythtv@…> Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

last night myth stopped recording, I didn't notice until just now when the watch recordings screen wouldn't load. I attached gdb and followed the wiki, hopefully I captured whatever went wrong.

Attachments (2)

gdb.txt (132.7 KB) - added by Steven Adeff <adeffs.mythtv@…> 8 years ago.
gdb attached
mythbackend.log.gz (47.9 KB) - added by Steven Adeff <adeffs.mythtv@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Steven Adeff <adeffs.mythtv@…>

Attachment: gdb.txt added

gdb attached

Changed 8 years ago by Steven Adeff <adeffs.mythtv@…>

Attachment: mythbackend.log.gz added

comment:1 Changed 8 years ago by danielk

comment:2 Changed 8 years ago by danielk

Milestone: unknown0.25
Resolution: Fixed
Status: newclosed

In [5639e05e267de6b0074e1958a768bb8c2212b942]

Fixes #10518. Fix CetonStreamHandler? deadlock. This wasn't a QMutex deadlock like most of them are, this was caused by variable aliasing preventing the _error signal from CetonStreamHandler::run() from being communicated to StreamHandler::Start(). Thanks to Steven Adeff for reporting this and providing a good backtrace.

Note: See TracTickets for help on using tickets.