Opened 8 years ago

Closed 6 years ago

#10608 closed Bug Report - General (Invalid)

Resetting the frontend settings using --reset doesn't trigger a locale selection the next time the frontend is run

Reported by: Nicolas Riendeau Owned by: stuartm
Priority: minor Milestone: 0.27
Component: MythTV - General Version: Master Head
Severity: medium Keywords: reset, locale, l10n
Cc: Ticket locked: no

Description

Resetting the frontend settings using --reset (or -r) no longer triggers a locale selection the next time the frontend is started.

The frontend seems to use the system locale the next time the frontend is run as some sort of default but without using the settings defined in the locale file.

Change History (5)

comment:1 Changed 8 years ago by Nicolas Riendeau

Status: newassigned

comment:2 Changed 7 years ago by stuartm

Milestone: unknown0.26.1

comment:3 Changed 6 years ago by paulh

Milestone: 0.26.10.28

comment:4 Changed 6 years ago by stuartm

Milestone: 0.280.27
Status: assignedaccepted

comment:5 Changed 6 years ago by stuartm

Resolution: Invalid
Status: acceptedclosed

This is by design on systems where we have a matching locale defaults file. We assume that in 99% of cases the user is happy for the language used by MythTV to match the system language. Those users wishing to override this can run change the language in the appearance settings or if for some reason that's not possible, they may run mythfrontend --prompt

Note: See TracTickets for help on using tickets.