Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10609 closed Bug Report - General (Fixed)

xv-blit video playback setting results in green purple tine

Reported by: spamoften2008@… Owned by:
Priority: minor Milestone: 0.25.1
Component: MythTV - Video Playback Version: 0.25-fixes
Severity: low Keywords: xv-blit
Cc: Ticket locked: yes

Description

Since upgrading to mythtv 0.25, the xv-blit video setting shows incorrect hues. Upgraded Unbuntu 10.04 to 12.04 Upgraded MythTv? 0.24 to 0.25

Mplayer configured to use xv-blit on the exact same videos shows proper color.

This is almost certainly due to a colorspace conversion problem in the default internal mythtv player.

The issue happens for recordings (720p, 1080i), and videos (xvid, mp4).

Using stock linux driver for Video hardware (LSPCI output): VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS480 [Radeon Xpress 200G Series]

Prior to my upgrade, video was perfect for 2 years...

The workaround to use opengl does not work as mythfrontend hangs and then comes back in a few minutes saying that it could not initialize video.

Workaround to use xshm results in stuttered video that is not acceptable, and uses all CPU on the system.

Change History (11)

comment:1 Changed 8 years ago by spamoften2008@…

Rebuilt from Mythbuntu 11.10 and then upgraded to myth 0.25 repository. Problem no longer exists. I will not be upgrading to ubuntu 12.04 as I am concerned the issue is linux kernel / driver related.

comment:2 Changed 8 years ago by danielk

Component: MythTV - GeneralMythTV - Video Playback
Priority: majorminor
Resolution: Invalid
Severity: mediumlow
Status: newclosed

Closing as invalid as reporter is not going to reproduce. If someone else has this problem please reopen.

comment:3 Changed 7 years ago by simons.philippe@…

Resolution: Invalid
Status: closednew

having the same issue

comment:4 Changed 7 years ago by danielk

Status: newinfoneeded_new

Simons, please attach the output of xvinfo and a log from "mythfrontend -v playback" from the playback of a short clip.

comment:5 Changed 7 years ago by sphery

Please also attach a file with the output of:

mythfrontend --version > $HOME/mythfrontend_version.txt 2>&1

This may have been fixed by b2657a1a3f8a

comment:6 Changed 7 years ago by simons.philippe@…

looks like I found what's happening

mythtv is setting the XV_HUE attribute to -1000 (which correspond to 0% in the Internal player) when setting the Hue to 50% in the Internal player, XV_HUE attribute is set back to 0 and colors are corrects.

and yes looks like my build is previous to b2657a1a3f8a

you can close this one for me.

comment:7 Changed 7 years ago by Raymond Wagner

Resolution: Fixed
Status: infoneeded_newclosed

comment:8 Changed 7 years ago by micha@…

It seems I do have this problem. Could this please be backported to the 0.25/fixes branch?

comment:9 Changed 7 years ago by ted@…

A quick workaround for anyone else who has the problem is during playback hit the F key to cycle thru video controls until you get to HUE (it will be set to 0%, if you have the problem) then set it to 50%, with the arrow keys. When I did this the current OSD didn't indicate which setting I was adjusting I just kept hitting F until it showed one at 0%.

comment:10 Changed 7 years ago by sphery

Ticket locked: set

Both b2657a1a3f8a (via 0f8476995f ) and 0c00c0ac9 (via 2e7722d43 ) are in 0.25-fixes. Anyone who is seeing this issue should update to current 0.25-fixes, but may still need to fix old/broken values for the settings using the Playback Picture Controls UI (hit F during playback), as described.

comment:11 Changed 7 years ago by stuartm

Picture controls are accessible via the OSD menu as well:

Menu > Video > Adjust Picture > Hue

Note: See TracTickets for help on using tickets.