Opened 7 years ago

Closed 7 years ago

#10637 closed Bug Report - General (Duplicate)

When recording name too long, watch recordings screen shows empty play group

Reported by: Amit.Margalit@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In the "Watch Recordings" screen of mythfrontend, the list on the left contains the names of recorded shows, and the right-side shows episodes.
In this screen, when the recording name exceeds some length, it will be shown, trimmed to fit on the left, but the right-side will show nothing and an ugly overlapping line of text appears:
"There are no recordings in your current view".
However, if I look at "All Recordings" I can find those episodes...
A screenshot is attached.

Attachments (1)

MythFrontend-bug.png (393.3 KB) - added by anonymous 7 years ago.
Screenshot.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by anonymous

Attachment: MythFrontend-bug.png added

Screenshot.

comment:1 Changed 7 years ago by Amit.Margalit@…

Looking at the source it seems clear that one possible reason for this is in programs/mythfrontend/playbackbox.cpp in PlaybackBox::updateRecList():

...
    QString groupname = sel_item->GetData().toString();
    QString grouplabel = sel_item->GetText();

    updateGroupInfo(groupname, grouplabel);

    if (((m_currentGroup == groupname) && !m_needUpdate) ||
        m_playingSomething)
        return;

    m_needUpdate = false;

    if (!m_isFilling)
        m_currentGroup = groupname;

    m_recordingList->Reset();

    ProgramMap::iterator pmit = m_progLists.find(groupname);
    if (pmit == m_progLists.end())
        return;
...

Seems like groupname is being read from sel_item, which means it is probably a partial group name string. Then when we call m_progLists.find(groupname) it finds nothing.

comment:2 Changed 7 years ago by Amit Margalit <Amit.Margalit@…>

A method to overcome this is to create a new recording group, with a shorter name, and ensure that all recordings of this show will be attached to the new recording group.

Then, change the view options to show recording groups.

You will still see the problem, but you will now have a line on the Watch Recordings screen for the new recording group, that shows the recordings on the right-side.

comment:3 Changed 7 years ago by beirdo

Owner: set to stuartm
Status: newassigned

comment:4 Changed 7 years ago by paulh

Amit, The text returned from MythUIButtonListItem::GetText?() is always the complete text only the displayed text is truncated.

Are you sure you aren't seeing the same problem fixed in #11200? Could the problem recordings have spaces at the start or end or have multiple spaces in the middle?

comment:5 Changed 7 years ago by Amit.Margalit@…

In at least one instance I have been able to determine that this is indeed the same case, so I guess this can be closed.

comment:6 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Duplicate
Status: assignedclosed

Thank you for reporting back. Closing as duplicate of #11200.

Note: See TracTickets for help on using tickets.