Opened 8 years ago

Closed 6 years ago

#10641 closed Bug Report - General (Works for me)

WSDL files served with MIME type text/html rather than text/xml

Reported by: Josh Triplett <josh@…> Owned by: dblain
Priority: minor Milestone: 0.27
Component: Bindings - XML/JSON Version: 0.25
Severity: medium Keywords:
Cc: Ticket locked: no

Description

WSDL files, such as /Dvr/wsdl, currently get served with a MIME type of text/html. They should get served as text/xml instead.

Change History (5)

comment:1 Changed 8 years ago by Raymond Wagner

Milestone: unknown0.25.1
Resolution: Duplicate
Status: newclosed

Duplicate of #10618

comment:2 Changed 8 years ago by Josh Triplett <josh@…>

Not as far as I can tell; that change just adds a MIME type for the .xslt files referenced from the wsdl, not for the wsdl files themselves.

comment:3 Changed 8 years ago by Raymond Wagner

Milestone: 0.25.1unknown
Resolution: Duplicate
Status: closednew

comment:4 Changed 8 years ago by Raymond Wagner

Status: newassigned

comment:5 Changed 6 years ago by cpinkham

Milestone: unknown0.27
Resolution: Works for me
Status: assignedclosed

Not sure what has changed since this ticket was added, but this works properly in master for me:

wget -O - -S http://192.168.3.95:6544/Dvr/wsdl --2013-06-28 00:15:16-- http://192.168.3.95:6544/Dvr/wsdl Connecting to 192.168.3.95:6544... connected. HTTP request sent, awaiting response...

HTTP/1.1 200 OK Date: 28 Jun 2013 07:15:21 Server: Linux 3.9.4-200.fc18.x86_64, UPnP/1.0, MythTV 0.27.20130624-2 Accept-Ranges: bytes Connection: Keep-Alive Content-Type: text/xml; charset="UTF-8" Content-Length: 30359

Length: 30359 (30K) [text/xml]

For reference, my production MythTV v0.25 system also returns text/xml for this same query, so closing as 'works for me'.

Note: See TracTickets for help on using tickets.