Opened 8 years ago

Closed 8 years ago

#10670 closed Bug Report - Crash (Duplicate)

periodic backend segfault in QMutex::lock() scanning EIT?

Reported by: andrew@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: MythTV - EIT Version: 0.25-fixes
Severity: medium Keywords: EIT segfault QMutex backend
Cc: Ticket locked: no

Description

I've had periodic crashes (once every day or two) of mythbackend using fixes/0.24 for a while and was hoping upgrading to 0.25 would fix things; but no cigar.

Backtrace (see attached for full trace) shows:

#0 0xb43508c5 in QMutex::lock() () from /usr/lib/qt4/libQtCore.so.4 #1 0xb6edd932 in QMutexLocker::QMutexLocker (this=0xade97178, m=0x88) at /usr/include/qt4/QtCore/qmutex.h:102 #2 0xb73ba2fd in TVRec::SetChannel? (this=0x0, name=..., requestType=4096) at tv_rec.cpp:3005 #3 0xb737be6c in EITScanner::run (this=0x906e248) at eitscanner.cpp:136 #4 0xb60c691b in MThread::run (this=0x90a4430) at mthread.cpp:319 #5 0xb60c6f9d in MThreadInternal::run (this=0x90a4bf0) at mthread.cpp:78 #6 0xb43543dc in ?? () from /usr/lib/qt4/libQtCore.so.4 #7 0xb41f0d02 in start_thread (arg=0xade97b70) at pthread_create.c:301 #8 0xb4036eae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Attachments (1)

mythbackend-0.25_backtrace2.txt (24.8 KB) - added by andrew@… 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by andrew@…

comment:1 Changed 8 years ago by danielk

Resolution: Duplicate
Status: newclosed

Duplicate of #10541.

Note: See TracTickets for help on using tickets.