Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10671 closed Bug Report - General (Invalid)

mythfrontend v0.25 telnet/network-control socket change locks out network-remote-control apps

Reported by: ivan.beveridge@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25
Severity: medium Keywords: telnet mythfrontend remote control
Cc: Ticket locked: yes

Description

See ticket #10654 for some background. It's been locked for some reason, so I was unable to add comments :(

In sort it seems MythTV mythfrontend has been ammended to close network-remote-control access that was open before.

With respect, this is an issue. Behaviour of the software has changed when using MythTV on a single machine (combined backend/frontend) which is probably the most common configuration.

If jrsantos is correct, bahaviour has changed from creating a 'control socket' on all interfaces, to only localhost. My experience is that something that used to work with MythTV < v0.25.

Whilst this may have been the originally intended behaviour, a very useful ecosystem has grown up around this old functionality (of being able to access the 'Telnet' interface over the network) - "network remote control" apps on iphoneOS/iOS and Android etc. (Search for "mythtv" in iTunes store and Google Play store).

This change of functionality means that these apps stop working. AppleTV (and proably other PVR software) have such apps, so these changes in v0.25 (however "correct") mean that MythTV has lost functionality that AppleTV + iPhone has.

It would be good if MythTV frontend can be updated to permit access from the network (perhaps restricted by source IP/network), to allow this functionality back.

Change History (3)

comment:1 Changed 8 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

It has been locked because it was not a bug and got re-opened. MythTV stores many settings pre-profile, and if you do not specify the name to use through the 'LocalHostName?' parameter in mysql.txt, MythTV will default to using the name returned by hostname. As you have configured MythTV to listen only on 127.0.0.1 on that profile (hostname), either through intent or lack of action, it will do as told.

To resolve this, either go into mythtv-setup and tell MythTV to listen somewhere you can access from the network, or specify a profile to use in ~/.mythtv/mysql.txt with 'LocalHostName?' such that the IP selection is unset, causing mythfrontend to default to listening on all available private network addresses.

comment:2 Changed 8 years ago by davidkwood@…

Well, you certainly found an effective way to annoy your users. You changed a default behavior and broke everyone using IP remotes.

Obviously this is your prerogative - please do carry on.

comment:3 Changed 8 years ago by Raymond Wagner

Ticket locked: set
Note: See TracTickets for help on using tickets.