Opened 8 years ago

Closed 8 years ago

#10711 closed Bug Report - General (Invalid)

Mythtv stopped recording. Time format issues? "0000-00-00 00:00:00"

Reported by: Hans66 <hans66@…> Owned by:
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.24.2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Setup

Last week recording stopped. When I record a new program, is is added to recording schedule with time 0000-00-00 00:00:00 (MythWeb)

I did do my regular Debian updates; I think that PHP got updated. Not sure if that is related.

Attachments (1)

recording.png (140.3 KB) - added by Hans66 <hans66@…> 8 years ago.
screenshot of recording schedule showing 0000-00-00 00:00:00

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Hans66 <hans66@…>

Attachment: recording.png added

screenshot of recording schedule showing 0000-00-00 00:00:00

comment:1 Changed 8 years ago by Hans66 <hans66@…>

Hmm, I noticed also the following errors in Mythweb "upcoming" Warning at /usr/share/mythtv/mythweb/modules/tv/upcoming.php, line 95: !NoTrans: Invalid argument supplied for foreach()!! Warning at /usr/share/mythtv/mythweb/modules/_shared/tmpl/default/header.php, line 16: !NoTrans: Cannot modify header information - headers already sent by (output started at /usr/share/mythtv/mythweb/includes/errors.php:150)!!

Applying the fixes mentioned in ticket 10142 makes the errors go away, but not the recording issues. Recording are still scheduled with LastRecorded? "0000-00-00 00:00:00"

comment:2 Changed 8 years ago by Hans66 <hans66@…>

I did a complete new "install" of the mysql database (delete/create, start from scratch). I still have the php errors. This specific mythtv version is already running for a while. Issues are caused by the debian php update from squeeze8(?) to squeeze9. I can only revert to squeeze3 for php. Should I try this?

comment:3 Changed 8 years ago by Hans66 <hans66@…>

Please reject defect. I resolved it myself. Somehow I changed the ownership from mysql db mythconverg from mysql.mysql to mysql.adm. This gives following error (see below)...very hard to trace back to mysql ownership issue. (to be honest..I don't understand why it happens, the database is owned by mysql; the group mysql does not have additional members)

Query was: CREATE TEMPORARY TABLE sched_temp_record LIKE record; Driver error was [2/1004]: QMYSQL3: Unable to execute statement Database error was: Can't create file '/tmp/#sql6607_1ce_0.frm' (errno: 9)

comment:4 Changed 8 years ago by danielk

Resolution: Invalid
Status: newclosed
Note: See TracTickets for help on using tickets.