Opened 7 years ago

Closed 6 years ago

#10761 closed Bug Report - General (Upstream Bug)

The "Please wait" message for playback has become too small in Arclight with opengl painter

Reported by: yiannividalis@… Owned by:
Priority: minor Milestone: unknown
Component: Themes Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This problem appeared in the last two weeks, but I cannot be more specific on the commit.

Upon entering playback, the "Please wait' message is smaller than it used to be. If I exit playback and re-enter playback it becomes even smaller.

It happens on every frontend that's uses opengl painter, with openSuSE 12.1 and nvidia 295.20 drivers.

If I change the theme painter to Qt, the text size is back to normal.

MythTV Version : v0.26-pre-392-g06166e0-dirty
MythTV Branch : master
Network Protocol : 74
Library API : 0.26.20120509-1
QT Version : 4.7.4
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_libcrypto using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2 using_libudf

My xorg.conf, if it's needed:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.35  (buildmeister@builder97.nvidia.com)  Wed Jun 16 19:15:05 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "DPI" "120 x 120"
    Option "CustomEDID" "DFP-1:/etc/edid.bin"
    #Option "ModeValidation" "NoDFPNativeResolutionCheck"
    #Option "ExactModeTimingsDVI" "True"
#    Option "UseDisplayDevice" "DFP-1"
#    Option "ConnectedMonitor" "DFP-1" 
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "off"
EndSection

Attachments (1)

workaround.diff (306 bytes) - added by Kenni Lund [kenni a kelu dot dk] 6 years ago.
Workaround for the issue.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by mtw@…

I see the same behavior in 0.25.2 on Ubuntu.

MythTV Version : v0.25.2-15-g46cab93 MythTV Branch : fixes/0.25 Network Protocol : 72 Library API : 0.25.20120506-1 QT Version : 4.8.1 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

comment:2 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Paul Harrison posted the following comment and workaround on the mythtv-users mailing list:

The problem is with the animation stuff not working properly for that screen, there is a similar problem if you put an animated image on there as well. My guess is the animation never completes and so the dialog size never gets reset to it's proper size. Removing from="windowslideup" from the "videowindow" window definition in Arclights base.xml should at least prevent the problem.

comment:3 Changed 6 years ago by yiannividalis@…

Hi, Kenni, thanks for the tip.

I saw Paul's post, however I no longer use Arclight, since it's been abandoned by its creator.

I don't know what to suggest for this ticket, since it no longer affects me. I'll leave it up to you (the devs) to decide whether it should be left open or closed as fixed/invalid.

Thanks again for the update.

Yianni.

Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Attachment: workaround.diff added

Workaround for the issue.

comment:4 Changed 6 years ago by cpinkham

Resolution: Upstream Bug
Status: newclosed

Closing ticket since the Arclight theme is not maintained as part of MythTV.

Note: See TracTickets for help on using tickets.