Opened 7 years ago

Closed 7 years ago

#10920 closed Bug Report - General (Invalid)

Failure to record DVB radio

Reported by: Ian Richardson <grandmastermarclar@…> Owned by: danielk
Priority: minor Milestone: 0.26.1
Component: MythTV - Recording Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

Been unable to record or listen to radio available on Freeview, Freesat, or Hotbird for several weeks. Just noticed, as an example, the following in my 0.25-fixes mythbackend.log

Jul 16 21:58:04 babcom mythbackend[2153]: I Scheduler scheduler.cpp:2514 (HandleRecordingStatusChange) Tuning recording: "I'm Sorry I Haven't a Clue": channel 1708 on cardid 1, sourceid 1
Jul 16 21:58:04 babcom mythbackend[2153]: E DVBRead dtvsignalmonitor.cpp:384 (HandlePMT) DTVSM(/dev/dvb/adapter0/frontend0): We want 0 audio and 1 video streams
			But have 1 audio and 0 video streams

Change History (7)

comment:1 Changed 7 years ago by Raymond Wagner

Milestone: 0.25.1unknown
Priority: majorminor

comment:2 Changed 7 years ago by Raymond Wagner

Description: modified (diff)

comment:3 Changed 7 years ago by amb@…

In my experience (as a user and not a developer for a long time) recording from DVB radio channels does work but only if an "Audio only" recording profile is created.

I still think though that needing to create (or modify, see #9457) a custom profile to be able to record from a radio channel is a bug and would like to see this fixed so that the "Default" profile works.

comment:4 Changed 7 years ago by stuartm

Component: MythTV - GeneralMythTV - Recording
Milestone: unknown0.26.1
Owner: set to danielk
Status: newassigned

Seems like this might be related to the recorder refactor

comment:5 Changed 7 years ago by J.Pilk@…

This is a 'not me too' post. I've never had problems recording radio from dvb-t. I do it every day and I believe that others on the user list do too. All my recording profiles are set to 'Normal'. ATrpms build of v0.25.2-25-g0817eb2 from 29 Sept on f16 and on SL6.

comment:6 Changed 7 years ago by danielk

Status: assignedinfoneeded

Ian, is looks like you might have the recording profile settings set to record "TV Only". Can you please check that you are either using "Normal" or "Audio Only" profile?

comment:7 Changed 7 years ago by danielk

Resolution: Invalid
Status: infoneededclosed

Info not provided.

Note: See TracTickets for help on using tickets.