Opened 9 years ago

Closed 22 months ago

#9457 closed Bug Report - General (Won't Fix)

Custom Recording Profiles Unuseable

Reported by: amb@… Owned by: stuartm
Priority: minor Milestone: 0.28.2
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is the same as ticket #5734 but for recording profiles instead of transcoding profiles.

It is possible to define new recording profiles but it is not possible to select them when scheduling a recording because they do not show up in the list of available profiles.

In StoreOptEditor::Load() at line 720 of scheduleeditor.cpp the list of recording profiles available is found by calling RecordingProfile::listProfiles(0). This function at line 1566 of recordingprofile.cpp has a special case for profile number 0 which just returns the list {"Default", "Live TV", "High Quality", "Low Quality"}. There is nothing that will pick up the names of newly defined recording profiles.

Change History (13)

comment:1 Changed 8 years ago by stuartm

Milestone: unknown0.25
Owner: set to stuartm
Status: newaccepted

comment:2 Changed 8 years ago by stuartm

Type: Bug ReportBug Report - General

comment:3 Changed 8 years ago by stuartm

Milestone: 0.250.25.1

comment:4 Changed 7 years ago by Raymond Wagner

Milestone: 0.25.10.26

comment:5 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:6 Changed 7 years ago by stuartm

I don't actually think this is fixable. We might want to disable the ability to create custom group names, the four built-in groups (which can be edited) should be enough?

The problem is that profiles are associated with a particular card type, we can't allow users to specify the use of a custom profile they've created for HDHomeRun recorders because we can't know which device the recording will ultimately be recorded on. The point of have four common named profiles per card is that no matter which device is used there will be a 'High Quality' defined for it.

There's another more dramatic course and that is dropping the recording profile stuff entirely. Despite my example using the HDHomeRun, the profiles really only apply to 'capture' cards in any meaningful way. These days most users are using digital and for the rest disk space is a lot cheaper, the facility to change encoding rates/resolutions for different recordings doesn't really seem to be worth the complexity it introduces to the code and the UI.

comment:7 in reply to:  6 Changed 7 years ago by amb@…

Replying to stuartm:

I don't actually think this is fixable. We might want to disable the ability to create custom group names, the four built-in groups (which can be edited) should be enough?

As the original bug reporter, I will explain why I needed a new recording profile.

I record from DVB (DVB-T in the UK) and quite a lot of what I record are radio programs. One of the options available in the profile editor is "Recording Type" which can be "TV only", "Audio only" or "Normal". I added a new recording profile of "Radio" that uses "Audio only" because I think there is (or there was) a problem with trying to record video from a radio-only channel. I could have edited the "Low quality" profile and used that for radio but using something with one name to represent something else if a bit of a kludge. My solution was to raise this bug report and patch my code to offer "Radio" as a profile.

If you do delete the ability to create new profiles then there should be a built-in profile to match each of the options currently available. For DVB cards this would be a "Normal", "TV only" and "Audio only" profile and this would, as you suggest, remove the need for creating or editing profiles.

comment:8 Changed 7 years ago by stuartm

If there is a problem recording radio only channels then that's the bug we should be fixing. Can you please file a ticket for that issue if you are still having problems recording radio in the UK? It was working the last time I tested it, although playback was broken.

Allowing creation of custom profiles, or even allowing profiles at all is not a fix for that, it's a workaround.

comment:9 in reply to:  8 Changed 7 years ago by amb@…

Replying to stuartm:

If there is a problem recording radio only channels then that's the bug we should be fixing. Can you please file a ticket for that issue if you are still having problems recording radio in the UK? It was working the last time I tested it, although playback was broken.

Recording DVB radio has been broken and fixed several times as far as I know. The current situation as far as I can see is that bug #10920 says that recording doesn't work in 0.25-fixes unless "Audio only" is used and this is what I saw when I tested it today (error was "Only 0 video streams seen in PMT, but 1 are required.").

There are also problems with playback like bugs #10833 and #9666 as well although I have no problem other than slow seeking at program playback start.

Allowing creation of custom profiles, or even allowing profiles at all is not a fix for that, it's a workaround.

I agree with you, but allowing custom profiles that you can't use is a bug. As I said above I would be happy if the creation of custom profiles was removed provided that there is one built-in profile for each existing recording option.

comment:10 Changed 6 years ago by paulh

Milestone: 0.26.10.28

comment:11 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.280.28.1

Moving unresolved tickets to next point release

comment:12 Changed 3 years ago by Stuart Auchterlonie

Milestone: 0.28.10.28.2

Moving remaining open 0.28.1 tickets to 0.28.2

comment:13 Changed 22 months ago by Stuart Auchterlonie

Resolution: Won't Fix
Status: acceptedclosed

Closing any remaining tickets for 0.28, if the issue persists, feel free to reopen and align to v29 or master

Note: See TracTickets for help on using tickets.