Opened 9 years ago

Closed 7 years ago

#9666 closed Bug Report - General (Fixed)

Playing back an in-progress DVB-T radio recording keeps stopping early

Reported by: John Veness <John.Veness.mythtv@…> Owned by:
Priority: minor Milestone: 0.27
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

If I try to playback a DVB-T radio recording (in my case, something on BBC Radio 4 on UK Freeview) while it is currently recording, the playback keeps stopping before the end of the program. Not only that, but there is no bookmark set on exit, so I cannot resume from where it exited easily (so the problem isn't that I'm accidentally pressing Esc, as that would set a bookmark with my settings).

What seems to be happening is as follows:

Say that 5 minutes of the program have been recorded so far. I start playback from the beginning of the recording. After roughly 5 minutes of playback, the playback stops. At this point, roughly 10 minutes of the program have been recorded. If I immediately start playing again and skip to roughly 5 minutes, where playback stopped last time, playback will continue until roughly the 10 minute mark, at which point it will stop.

It's as if Myth is "remembering" the length of the recording at the point that you start playback, and is using that as the position to stop playback, even though additional minutes have since been added to the end of the recording.

Note that this seems to only be the case on DVB-T radio programs. DVB-T video programs *can* be watched while a recording is in progress with no problems.

Watching in-progress DVB-T radio programs is not something I do very often, so I'm not sure when this problem started exactly, but I do remember successfully playing them back a few months ago (I might have been using 0.22 then).

Attachments (1)

version_info (661 bytes) - added by Raymond Wagner 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by markk

Milestone: unknown0.24.1
Owner: set to tralph
Status: newassigned

comment:2 Changed 9 years ago by dekarl@…

Another datapoint, with fixes/0.24 DVB-T Video recordings work like expected for on a combined FE/BE (upgraded KnoppMyth?) after showing the same issue earlier (got fixed apparently, I'm not sure if it was around fixes/0.23 or 0.24) But a DVB-T Video recording does still show the issue with an fixes/0.24 on an Windows Frontend connected to a fixes/0.24 Backend (Mythbuntu).

comment:3 Changed 9 years ago by Raymond Wagner

Description: modified (diff)

Changed 9 years ago by Raymond Wagner

Attachment: version_info added

comment:4 Changed 9 years ago by tralph

Owner: tralph deleted
Status: assignednew

comment:5 Changed 9 years ago by beirdo

Milestone: 0.24.1unknown

comment:6 Changed 7 years ago by stuartm

Milestone: unknown0.27
Resolution: Fixed
Status: newclosed

Can't reproduce with master/0.27, (BBC Radio 4), so this looks like it was fixed at some point

Note: See TracTickets for help on using tickets.