Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 21 months ago

Closed 13 months ago

Last modified 13 months ago

#10962 closed Bug Report - General (Fixed)

Elapsed time set to zero when pausing HD recordings; set to the correct value when play resumes

Reported by: Oliver Lupton <oliverlupton@…> Owned by: stichnot
Priority: minor Milestone: 0.25.4
Component: MythTV - Video Playback Version: 0.25-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

MythTV box receiving UK Freesat with S1/S2 tuners.

While watching a recording from a HD channel the OSD shows the correct elapsed time and the correct total time, but when playback is paused the elapsed time is set to zero. When playback is resumed the elapsed time is reset to the correct value and everything is ok again.

Recordings of SD channels behave as expected: the correct elapsed time is displayed while paused.

Attachments (5)

version (821 bytes) - added by O Lupton <oliverlupton@…> 21 months ago.
mythbackend --version
play.png (1.4 MB) - added by O Lupton <oliverlupton@…> 16 months ago.
Screenshot while playing
paused.png (2.0 MB) - added by O Lupton <oliverlupton@…> 16 months ago.
Screenshot while paused (elapsed time is zero :-( )
mythbackend_version (822 bytes) - added by O Lupton <oliverlupton@…> 16 months ago.
Updated version of MythTV
mythfrontend.2013-03-21-11-21-47.log.bz2 (349.5 KB) - added by george Nassas <gnassas@…> 13 months ago.
sample logfile showing pause behaviour

Change History (25)

Changed 21 months ago by O Lupton <oliverlupton@…>

mythbackend --version

comment:1 Changed 20 months ago by wagnerrp

  • Milestone set to unknown

comment:2 Changed 20 months ago by stuartm

  • Owner set to stuartm
  • Status changed from new to accepted

comment:3 Changed 20 months ago by stuartm

  • Milestone changed from unknown to 0.26
  • Resolution set to Works for me
  • Status changed from accepted to closed

I can't reproduce this with 0.26 for BBC 1 HD, BBC HD, ITV1 HD, C4 HD nor NHK HD on Freesat. I'm going to say this is fixed but feel free to re-open if you are able to reproduce with 0.26 on release.

If you do re-open can you please include a screenshot so we know that we're all talking about the same thing? It could also be a theme specific issue so try another theme first.

comment:4 Changed 20 months ago by O Lupton <oliverlupton@…>

OK - I'll wait for the 0.26 release. FWIW I did confirm that the issue was there with several different themes.

Changed 16 months ago by O Lupton <oliverlupton@…>

Screenshot while playing

Changed 16 months ago by O Lupton <oliverlupton@…>

Screenshot while paused (elapsed time is zero :-( )

Changed 16 months ago by O Lupton <oliverlupton@…>

Updated version of MythTV

comment:5 Changed 16 months ago by O Lupton <oliverlupton@…>

I have now updated to 0.26 and I still see this problem. I have attached an updated mythbackend --version output, and screenshots of the issue.
play.png shows that during playback the display is as expected, paused.png shows how the displayed elapsed time is set to zero when playback is paused.

comment:6 Changed 13 months ago by geoffp@…

  • Resolution Works for me deleted
  • Status changed from closed to new

I can confirm that O. Lupton's screenshots reflect exactly the issue I see on 0.26.

comment:7 Changed 13 months ago by stichnot

  • Owner changed from stuartm to stichnot
  • Status changed from new to accepted

It works for me, but the screenshots are very convincing. I've spent some time pondering this, but I still can't come up with a plausible explanation.

Could you provide a mythfrontend log that demonstrates the problem? Please run with "-v all,norefcount --loglevel debug", which may produce a very large log file but hopefully all available clues will be intact.

Also, if you could provide a link to a ~50MB sample, that would be very helpful.

comment:8 Changed 13 months ago by geoffp@…

I will do that as soon as I get a chance, hopefully tonight. For what it's worth, I *believe* I started seeing this when I split my installation into a fully separate frontend & backend, though that may also be confounded by a few other things:

  • I believe the backend server is running Ubuntu 12.04 LTS and the frontend is running 12.10.
  • I started seeing it when I built a new frontend with new hardware and a fresh install.
  • I am using the mythbuntu repos on both frontend & backend, using packages that track the 0.26-fixes branch.

Changed 13 months ago by george Nassas <gnassas@…>

sample logfile showing pause behaviour

comment:9 Changed 13 months ago by George Nassas <gnassas@…>

I have been seeing the same behaviour on my system and just attached a log file with the requested options. Search down to "2013-03-21 11:22:17.791617" to find a "UpdateOSDSeekMessage(Paused, 0)" call that looks like the culprit. The sequence was start frontend, navigate to recordings screen, play the second show in the list (Conan), pause after a second or two, unpause, exit after a few seconds, exit all the way out of the application. It segfaults on the way out but I think that's due to memory corruption issues with the intel graphics drivers.

I'm running master from March 12 (v0.27-pre2-766-g20c0935) with a few non-playback patches. Mostly to fix problems with bonjour or thread safety, you can get the list by searching for open tickets with my name attached.

Like Geoff I started seeing the issue when I built my new machine which is a ivy bridge i7 on debian testing. And, as mentioned, I'm using the on-chip graphics if that makes any difference.

It's easy for me to update to current master and test patches should you want more logging etc.

Oh, the recording is a ATSC mpeg2 but the problem also happens with pvr-250/350 recordings also so if you have any of those around they'll trigger it. Basically pausing any mpeg2 seems to show the problem. I also tried pausing a dvd but the correct time stayed on the osd. There doesn't seem to be any problem with h.264 files, I tried a bunch of those too.

comment:10 Changed 13 months ago by geoffp@…

Oh, interesting! I'm also using VA-API + on-board graphics on an Ivy Bridge i5.

comment:11 Changed 13 months ago by geoffp@…

Might it be that the VA-API decoder is involved in reporting elapsed time, and the original reporter's playback profile was using VA-API for HD recordings but not SD?

(I'm also using ATSC mpeg2 recordings.)

comment:12 Changed 13 months ago by stichnot

Thanks for the diagnosis. I can now reproduce the problem when I use the VAAPI playback profile.

comment:13 Changed 13 months ago by Jim Stichnoth <jstichnoth@…>

In 841ff3a359ce668eb51ef1da917ffab5a0932302/mythtv:

Enable proper display of elapsed time when paused with VAAPI.

Make sure av_pause_frame is updated so that the player can pick up the
current frame number while paused. Refs #10962

comment:14 Changed 13 months ago by stichnot

George, please test the latest commit to Master. If that works and doesn't cause any regressions, I'll backport it to fixes.

comment:15 Changed 13 months ago by geoffp@…

Jim, I wish there was a way for me to thank you and write out that I appreciate the fix without Trac flagging my post as blogspam.

comment:16 Changed 13 months ago by George Nassas <gnassas@…>

I just tried a fresh master build against all the files that gave me problems this morning and they're all pausing fine now + no regressions on files that paused OK before. Thanks for the quick fix!

comment:17 Changed 13 months ago by Jim Stichnoth <jstichnoth@…>

In 6be8c10b39dcbe0fe825d22fec70795d87972a25/mythtv:

Enable proper display of elapsed time when paused with VAAPI.

Make sure av_pause_frame is updated so that the player can pick up the
current frame number while paused. Refs #10962
(cherry picked from commit 841ff3a359ce668eb51ef1da917ffab5a0932302)

Conflicts:

mythtv/libs/libmythtv/videoout_openglvaapi.cpp

comment:18 Changed 13 months ago by Jim Stichnoth <jstichnoth@…>

In 17696817489c31931bd0a6c4f0311d61d459ff76/mythtv:

Enable proper display of elapsed time when paused with VAAPI.

Make sure av_pause_frame is updated so that the player can pick up the
current frame number while paused. Refs #10962
(cherry picked from commit 841ff3a359ce668eb51ef1da917ffab5a0932302)

Conflicts:

mythtv/libs/libmythtv/videoout_openglvaapi.cpp

(cherry picked from commit 6be8c10b39dcbe0fe825d22fec70795d87972a25)

comment:19 Changed 13 months ago by stichnot

  • Milestone changed from 0.26 to 0.25.4
  • Resolution set to Fixed
  • Status changed from accepted to closed

comment:20 Changed 13 months ago by geoffp@…

Confirmed that this fix is present and working downstream in Mythbuntu 0.26-fixes. Thanks again!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.